Ошибка при установке Drupal 5 на Denwer

Аватар пользователя amonit amonit 27 декабря 2015 в 1:22

Нужно установить старенький Drupal 5

Денвер ругается

Deprecated: Function ereg() is deprecated in Z:\home\drupal5-test.ru\www\includes\file.inc on line 646

Warning: Cannot modify header information - headers already sent by (output started at Z:\home\drupal5-test.ru\www\includes\file.inc:646) in Z:\home\drupal5-test.ru\www\includes\install.inc on line 574

Warning: Cannot modify header information - headers already sent by (output started at Z:\home\drupal5-test.ru\www\includes\file.inc:646) in Z:\home\drupal5-test.ru\www\includes\install.inc on line 575

Понимаю, что функция ereg() устарела, но в 646й строке я ее не нашел. И вообще в файле file.inc не используется эта функция. Как решить эту проблему?
И вообще стоит ли заморачиваться? Не возникнет такая же проблема при заливке сайта на хостинг?
Старый drupal 5 нужен по причине того, что там есть необходимые модули и шаблоны, которые мне нужны. В новых версиях их уже нет.

0 Thanks

Комментарии

Аватар пользователя negociant negociant 27 декабря 2015 в 13:02
amonit wrote:

Старый drupal 5 нужен по причине того, что там есть необходимые модули и шаблоны, которые мне нужны. В новых версиях их уже нет.

Список этих модулей?

И для ознакомления https://www.drupal.org/drupal-6-eol