[РЕШЕНО] Nivo слайдер и Views делаем ссылку

Аватар пользователя 0legka 0legka 14 декабря 2011 в 13:27

Ребята, такая проблема: создал представление Nivo как объяснил на видео Андрей http://stepgt.com/content/drupal-6-ustanovka-nivo-slider-chast-2, но никак не получается назначить ссылки... если ставить ссылки на материал, чтобы я туда не ввёл, пишет "Ссылка Nivo: Не найден материал с таким заголовком.", если назначаю общую ссылку на всё представление, ну скажем node/73, ссылка по которой в результате переходишь получается вот такой http://localhost/Drupal/admin/build/views/edit/<а%20href="Drupal/node/73"> уже не знаю что и думать .. куда хоть рыть ?

P.S. в процессе поиска пути решения, было выявлено, что в поле "ссылка" создаваемого материала требуется вставить заголовок ноды, или nid, но но поле как то не правильно обрабатывается и дополняется каким то аргументом (если символ % это аргумент) и соответственно говорит что страница не найдена.

Комментарии

Аватар пользователя UnnamedNETUA UnnamedNETUA 14 декабря 2011 в 16:15

У вас в вьюхе есть вообще поле Заголовок?
Ну в нем есть пункт "Сделать это поле ссылкой на оригинальный кусок содержимого"

Аватар пользователя 0legka 0legka 15 декабря 2011 в 9:26

Спасибо за ответ, но заголовок я убрал, так как мне нужно просто слайд-шоу без всяких подписей, если его оставить, внизу слайдов выскакивает серое поле с названием картинки (
А ссылка, о которой ты говоришь, есть и в поле "ссылка" вот там то у меня галка и стоит, только при назначении любой ссылки материалу начинает ругатсо, что такого материала нет, вот собсно всвязи с этим и создан данный топик (

Аватар пользователя iehon iehon 15 декабря 2011 в 14:28

можешь сделать подобный скрин?
http://fastpic.ru/view/32/2011/1120/43282f7eb07e3495ddb98947bca19c92.png...
ссылка должна сразу ставиться.

+ можно проверить на работу ссылок. проставь стиль не "ниво слайдер", а "без форматирования" и посмотри будут ли верные ссылки выдаваться. возможно проблема в синонимах path или pathauto

Аватар пользователя 0legka 0legka 16 декабря 2011 в 9:40

"iehona" wrote:

Спс за помощь, всё сделал как на скрине, не помогает; поменял стиль, вообще перестало картинки выводить, вернул обратно... проверил path и pathauto - всё в норме... видимо нужно в код лезть..
ОДНАКО заметил вот такую закономерность:
в форме создания материала, в поле "ссылка" когда указываешь на материал к примеру node/73, он пишет что такого заголовка нет.. ну это логично, т.к. это адрес страницы, зато когда прописываешь заголовок страницы, он это хавает, и на слайдере перекидывает на не существующую страницу, поэтому просто создал шесть альтернативных адресов, с соответствием: заголовок - адрес страницы, и всё заработало....
Но это хак, должна же там быть кнопка, которая отвечает за тип ссылки в материале... но я не нашёл...(
Друзья, если кто знает, просьба отписаться, не хотелось бы так топорно делать свой первый сайт на Друпале Smile

Аватар пользователя iehon iehon 22 декабря 2011 в 14:00

впервые с таким сталкиваюсь.
модуль global redirect случайно не ставил?
после включения модуля path и pathauto можно в ноде редактировать ссылку страницы. это хотя бы работает?

Аватар пользователя 0legka 0legka 22 декабря 2011 в 16:25

"iehona" wrote:
впервые с таким сталкиваюсь.
модуль global redirect случайно не ставил?

Поставил тему splendid, её и подгоняю под свои нужды, возможно такие заморочки и были задуманы автором....
Ставил Path redirect но он давненько уже отключен...
"iehona" wrote:
после включения модуля path и pathauto можно в ноде редактировать ссылку страницы. это хотя бы работает?

дело в том, что я ещё очень зелёный сайтостроитель, где хоть это посмотреть можно ?

Аватар пользователя iehon iehon 23 декабря 2011 в 2:11

если статьи открываются, значит ссылки работают

а проверить в теме дело или нет можно включив стандартную и проверить заработает или нет )