[Решено] Дублирование Image title в album photos

Аватар пользователя kosmaty kosmaty 13 марта 2010 в 23:28

Доброго всем. Есть такая проблема (хотя может и нет, но выглядит не очень) есть модуль album photos, в котором прописываются титлы к каждой новой добавленной фотографии, при просмотре альбома выясняется что этот заголовок дублируется. Выглядит это, прямо скажем, не очень грамотно. Вопрос - где это убрать?

вот пример картинки
Буду признателен за помощь.

Комментарии

Аватар пользователя kosmaty kosmaty 15 марта 2010 в 9:16

"117_tumb" wrote:
Замените photos.css этим файлом и очистите кэш.

Вот спасибо, добрый человек! на досуге поищу 10 отличий!)

Аватар пользователя kosmaty kosmaty 15 марта 2010 в 10:25

так... я, конечно, человек не совсем умный, но diff мне сказал, что они абсолютно одинаковы... не поверил, посмотрел глазами - одинаковые... как это понять? что за танец с бубном был исполнен? или что за обряд такой - "входит и выходит - замечательно выходит"!..
я ничего не понял)

117_tumb, Вы шаман?

Аватар пользователя 117_tumb 117_tumb 15 марта 2010 в 15:12

Человек Вы, безусловно, умный, однако начали немного не с того конца. Ознакомьтесь с основами HTML и CSS, иначе, чем дальше, тем больше будет вопросов.

Строки 269,273. Это простейшее решение Вашей проблемы, на скорую руку. В дальнейшем, при определённых условиях, оно может вызвать другие проблемы – с отображением названия фото.

Аватар пользователя kosmaty kosmaty 15 марта 2010 в 16:56

"117_tumb" wrote:
Ознакомьтесь с основами HTML и CSS, иначе, чем дальше, тем больше будет вопросов.

понял, буду заниматься.
как я понял, в данном случае, текст просто спрятали, а берется же он не из css.

"kosmaty" wrote:
но diff мне сказал, что они абсолютно одинаковы..

видать с недосыпа сверял файл сам с собой)
Спасибо.

Аватар пользователя kosmaty kosmaty 15 марта 2010 в 18:02

методом научного тыка все решилось, правда не знаю, насколько это технически и философски грамотно, но пока ничего не ругается и все работает, как должно

Порылся в файле photos_imageview.tpl.php там нашел такую вот строку <?php print $image['filename'];?>, удалил ее, может это, конечно, политически не корректно, но сработало)

Аватар пользователя 117_tumb 117_tumb 15 марта 2010 в 18:44

Разумеется, некорректно, я этого делать не стал, предложил Вам решение с минимальными, по-моему, побочными эффектами. Нужно разбираться, как создаётся нода с изображением. У меня на это сейчас нет времени, тем более всё и так работает нормально, без трюков.