Не работает image_fupload и uploadify [Решено]

Аватар пользователя juliv juliv 9 февраля 2010 в 11:56

Здравствуйте.
Сегодня столкнулся с проблемой, что надо поставить пакетную загрузку изображений на сайт.
Выбрал два модуля: Image_fupload и Uploadify.
Оба модуля сразу же заработали на локахосте (xammp), но отказываются работать на сайте.
В обоих случаях при загрузке файлов пишется ошибка (в случае Uploadify):
1. окошко "HTTP"
2. Второе окошко "503"
И после этого блок с названием файла подсвечивается красным (и файл, естественно, не загружается).

Ставил в настройках htaccess:
php_value upload_tmp_dir site/public_html/tmp
на папку права 777

Загрузка обычными средствами imagefield производится вполне нормально.

Что требуется настроить дополнительно, чтобы заработало?

0 Thanks

Комментарии

Аватар пользователя juliv juliv 9 февраля 2010 в 12:26

Логи друпала ничего не показывают, а на хостинге их нет. Есть только статистика webalizer, которая почему-то тоже отказывается работать.
доступа к php.ini также к сожалению нет.
Могу только предоставить phpinfo

upload_max_filesize     20M     6M
upload_tmp_dir  /www/htdocs/tmp no value
user_dir        no value        no value

P.S. Также пользовался комментарием http://habrahabr.ru/blogs/jquery/71772/#comment_2056777

Аватар пользователя juliv juliv 9 февраля 2010 в 12:36

Простите, потопился с созданием топика.
Ставил ссылку на upload_tmp_dir неправильную.
Сейчас поставил другую и заработало!

Я так понимаю, что если не установлена и/или нельзя установить upload_tmp_dir,
то множественная загрузка посредством этих модулей (читай через flash) недоступна?

Аватар пользователя Shtat Shtat 13 июля 2010 в 0:24

Если не сложно, чуть по-подробнее расскажите, как исправить эту ошибку.

Аватар пользователя Shtat Shtat 13 июля 2010 в 0:24

Если не сложно, чуть по-подробнее расскажите, как исправить эту ошибку.

Аватар пользователя Shtat Shtat 13 июля 2010 в 0:24

Если не сложно, чуть по-подробнее расскажите, как исправить эту ошибку.