HTTP ошибка 0 при загрузке imagefield

Аватар пользователя Maddoc Maddoc 4 февраля 2010 в 21:56

Подскажите, в чем может быть проблема?
При загрузке изображений через imagefield explorer, opera, firefox все загружают без проблем.
Но при попытке загрузить через Google Chrome выдает ошибку "Обнаружена HTTP ошибка 0" или "An HTTP error 0 occurred" в буржуйском варианте. Получает ошибка происходит уже на стороне клиента при получении данных.
Поиск юзал, но ничего именно насчет Google Chrome не нашел. Читал вроде, что аналогичные проблемы раньше были с оперой.

Комментарии

Аватар пользователя Maddoc Maddoc 5 февраля 2010 в 3:00

Memory_limit 64Mb
Размер любой
Загвоздка в том, что в других браузерах все нормально.

Обнаружил, что в хроме не хочет даже добавляться новое поле для загрузки изображения. Выдает уже ошибку с "Обнаружена HTTP ошибка 0. \n/content/js_add_more/..."
Ничего не могу понять:(

Аватар пользователя serega.kalina serega.kalina 8 марта 2010 в 2:09

А если не кликать "загрузить" а просто сохранить добавление/редактирование node то все нормально.
Сам не знаю чё делать!!!!!

Аватар пользователя serious.vip@drupal.org serious.vip@dru... 7 июня 2010 в 20:05

Прямо некропостинг какой-то...
Откройте developer tools (инструменты разработчика) - и уже на нем активируйте вкладку resources (ресурсы). Потом повторите злосчастный запрос - и пришлите скриншот/копипаст или что-то подобное собственно запроса, причем и вкладку Headers (заголовки), и вкладку Content (содержимое)
После этого уже можно будет детально обсудить, что же вас там так беспокоит 4 месяца как.

Аватар пользователя korj@drupal.org korj@drupal.org 10 ноября 2015 в 11:46

на drupal.ru - при "прикреплении файла" тоже вылетает HTTP-ошибка 0
Chrome самый последний 5.0.375.55

кто хромом пользуется - попробуйте приаттачить к комменту файл!

equest URL:http://drupal.ru/comment-upload/js
Request Method:POST
Status Code:200 OK
Request Headers
Accept:application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
Content-Type:multipart/form-data; boundary=----WebKitFormBoundaryEtSC7oSRRHVr1G6F
Origin:http://drupal.ru
Referer:http://drupal.ru/node/39932
User-Agent:Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.55 Safari/533.4
Request Payload
 ------WebKitFormBoundaryEtSC7oSRRHVr1G6F
Content-Disposition: form-data; name="comment"

------WebKitFormBoundaryEtSC7oSRRHVr1G6F
Content-Disposition: form-data; name="format"

4
------WebKitFormBoundaryEtSC7oSRRHVr1G6F
Content-Disposition: form-data; name="form_build_id"

form-a006280b6e5bac5c8807e253a74c38a1
------WebKitFormBoundaryEtSC7oSRRHVr1G6F
Content-Disposition: form-data; name="form_token"

e3e8afbfb043c55cb9a4a265cc13513c
------WebKitFormBoundaryEtSC7oSRRHVr1G6F
Content-Disposition: form-data; name="form_id"

comment_form
------WebKitFormBoundaryEtSC7oSRRHVr1G6F
Content-Disposition: form-data; name="files[upload]"; filename="7.jpg"
Content-Type: image/jpeg

------WebKitFormBoundaryEtSC7oSRRHVr1G6F
Content-Disposition: form-data; name="notify_type"

0
------WebKitFormBoundaryEtSC7oSRRHVr1G6F--
Response Headers
Cache-Control:store, no-cache, must-revalidate, post-check=0, pre-check=0
Connection:keep-alive
Content-Encoding:gzip
Content-Type:text/html; charset=utf-8
Date:Mon, 07 Jun 2010 20:17:16 GMT
Expires:Sun, 19 Nov 1978 05:00:00 GMT
Keep-Alive:timeout=20
Last-Modified:Mon, 07 Jun 2010 20:17:16 GMT
Server:nginx/0.8.36
Transfer-Encoding:chunked
X-Powered-By:PHP/5.2.13-pl0-gentoo

Аватар пользователя korj@drupal.org korj@drupal.org 8 июня 2010 в 15:24

потратил не один час с переустановками chrom'а пока не нашел причину: расширение SmoothScroll !
каким боком оно завязано с исполнением друпаловского js - я не знаю, но кроме друпала глюков я нигде пока не замечал

Аватар пользователя ihappy ihappy 22 июня 2010 в 14:37

Спасибо, помогло.
Долбаный плагин конфликтует с друпалом. Вообще дикость какая то.