Проблема с PCRE-библиотекой

Аватар пользователя Dr. Hardcore Dr. Hardcore 24 октября 2006 в 9:42

Установил drupal на сервер и начал его настраивать. Ввожу название сайта, включаю чпу и т.д. и нажимаю сохранить настройки. В ответ мне сообщение: Настройки не сохранены, потому что вы имеете устаревшую версию библиотеки PCRE. Подробности на сайте www.php.net/pcre. Позвонил провайдеру, сказали, что библиотеку обновлять не будем, разбирайтесь сами. Что мне делать? Можно ли как нибудь обойти эту проблему? Отказываться от drupal мне очень не хочется. Помогите пожалуйста.

Комментарии

Аватар пользователя inc inc 24 октября 2006 в 20:09

Какая установлена версия PHP?
Версия должна быть не меньше 4.3.3.

Аватар пользователя Dr. Hardcore Dr. Hardcore 25 октября 2006 в 18:56

Да по-моему эта и стоит, все же работает, только пишет, что эта библиотека старая. Что делать? Или эту версию не вариант использовать?

Аватар пользователя inc inc 25 октября 2006 в 20:45

Чтобы точно узнать какая именно версия PHP надо создать файл info.php с кодом <?php echo phpinfo(); ?> и запустить его.

Аватар пользователя Dan Dan 5 ноября 2006 в 1:48

Можно собрать свой php (в режиме cgi) с нужными библиотеками (ещё mbstring посмотрите - включен?). Проконсультируйтесь у провайдера как это сделать.