Что нужно сделать, чтобы запустить под MYSQL 5?

Аватар пользователя Гость Гость (не проверено) 10 мая 2006 в 10:40

Здравствуйте!
Что нужно сделать, чтобы запустить под MYSQL 5?
Как только поставил MYSQL 5, перестал работать Drupal.

Лучший ответ

Комментарии

Аватар пользователя axel axel 12 мая 2006 в 13:46

Я думаю стоит, поскольку в PHP5 заявлен некоторый прирост производительности (правда на каких функциях?). Но я думаю хуже не будет. Ставил на PHP5+MySQL4.1, дома локальные сайты на PHP5+MYSQL5 - если апгрейд MySQL прошёл нормально и СУБД работает, то проблем нет.
На продуктивных серверах использую PHP4, только по той причине что в дистрибутиве Debian Sarge поставляется PHP4, а я все сервера на этом дистре строю. Иначе ставил бы тоже PHP5.

Кстати, можно ведь ставить одновременно PHP4 и PHP5 - конфиги у них лежат отдельно, и под апач можно настроить например PHP4 через mod_php, а PHP5 через CGI/suphp - для экспериментов на отдельных сайтах.

--
Axel,
Darcs-репозиторий разработок для Drupal