D9 библиотеки

Аватар пользователя kari kari 17 июня в 19:34

Осваиваю 9. Помогите пожалуйста разобраться с установкой библиотек. Например, необходимо установить библиотеку для color field. Сам модуль установлен через composer. Также установлен модуль Librariesю. Затем, пытясь следовать указаниям readme модуля color field, сайт был пару раз уложен на обе лопатки. Поэтому обращаюсь за помощью.
Как я понимаю, в девятке нет привычной папки libraries, а есть файл libraries.yml Но в документации про него не сказано. А сказано вот что:
______________________________
Install as you would normally install a contributed Drupal module.
--------------------------------------------
- сделано, как описано выше, установлен модуль color field через composer
Далее сказано, что для доступа к различным отображениям поля мне понадобится дополнительно библиотека JS
Читаем дальше
______________________________
If you installed color field via [Composer](https://getcomposer.org), the packages will have been suggested but not automatically installed. If you have Asset Packagist already configured - as most Commerce users will - skip to just requiring the desired package(s).
```bash
composer require bower-asset/jquery-simple-color bower-asset/spectrum
--------------------------------------------
Нет, Asset Packagist у меня нет, читаю дальше
--------------------------------------------
Otherwise, to install them you will need to add [Asset Packagist](https://asset-packagist.org) to your composer.json and do some and make a couple other changes to your `composer.json`. Specifically, in the `extra` key add/adjust current values:
"installer-types": [
"npm-asset",
"bower-asset"
],
"installer-paths": {
"web/core": [
"type:drupal-core"
],
... (сокращаю)
then run
```bash
composer require oomphinc/composer-installers-extender
composer require bower-asset/jquery-simple-color bower-asset/spectrum
--------------------------------------------
Вот тут, вероятно, я делаю что-то не так. Я добавляю запись "installer-types" и еще добавляю набор записей в "installer-paths" в файле composer.json. Затем через терминал в корне сайта командами
composer require oomphinc/composer-installers-extender
composer require bower-asset/jquery-simple-color bower-asset/spectrum
грохаю сайт. При этом грохается, судя по всему, именно первой командой, и как я понимаю, она сносит модуль libraries, из-за чего сайт ругается, что не обнаружен установленный модуль.
Я возвращаю модуль на место, сайт встает с колен, и я пытаюсь обойтись второй командой
composer require bower-asset/jquery-simple-color bower-asset/spectrum
но получаю в терминале ответ:
[Seld\JsonLint\ParsingException]
"./composer.json" does not contain valid JSON
Parse error on line 15:
... } { "type": "c
-------------------^
Expected one of: 'EOF', '}', ',', ']'

Направьте меня, пожалуйста, джуна неопытного, на путь истиный.

Лучший ответ

Аватар пользователя ivnish ivnish 18 июня в 7:06

Запятой не хватает

Комментарии

Аватар пользователя OldWarrior OldWarrior 18 июня в 0:56

kari wrote: Parse error on line 15:
... } { "type": "c

Что именно у вас на 15-й строке?

kari wrote: Expected one of: 'EOF', '}', ',', ']'

Что-то где-то пропустили: фигурную скобку, запятую... etc.
Либо - в чём правите файл, в каком редакторе, а точнее - в какой кодировке?

Аватар пользователя kari kari 18 июня в 6:39

В 15 строке у меня
}
Относится эта скобка сюда:
"repositories": [
{
"type": "composer",
"url": "https://packages.drupal.org/8"
} //15 строка

{
"type": "composer",
"url": "https://asset-packagist.org"
}
],
кодировку не знаю как посотреть, вижу только как перекодировать (работаю в sublime)