Установка отдельного пакета с помощью composer

Аватар пользователя marassa marassa 1 февраля 2021 в 9:50

Имеется сайт на восьмерке, который пока не ведется в композере (ну так вышло, виноват, сейчас не об этом). Позарез нужно поставить один компонент, который корректно ставится только композером (autoupload, PSR-4 и т.д.). Сам композер есть (от хостера), composer.json тоже какой-то есть (из дистрибутива, не соответствует реальной конфигурации).
Вопрос: если я тихонечко запущу
composer require d8-contrib-modules/cloudflarephpsdk
то композер тихонечко доставит только этот пакет, или разнесёт мой сайт в клочья? Wink

Комментарии

Аватар пользователя marassa marassa 1 февраля 2021 в 10:23

Ну вот, пока ждал ответа от гуру, случайно запустил ту команду на проде Wink
Сайт вроде пока жив. Тестировать что сломалось или сразу с бэкапа восстанавливать? Wink

Аватар пользователя buddy90210 buddy90210 1 февраля 2021 в 10:25

Полагаю доставил пакет) и на сколько я понимаю поставил его по путям прописанным в composer.json
Может и нечего страшного)

Аватар пользователя marassa marassa 1 февраля 2021 в 10:39

Ну да, поставил в папку vendor, плюс много файлов обновилось в папке vendor/composer, но вроде ничего ужасного не произошло.

Аватар пользователя marassa marassa 2 февраля 2021 в 11:06

marassa wrote: вроде ничего ужасного не произошло

Рано радовался: совершенно случайно обнаружил, что composer при выполнении команды
composer require d8-contrib-modules/cloudflarephpsdk
зачем-то сбросил до исходного состояния .htaccess и robots.txt, в которых у меня была КУЧА кастомизаций. Восстановил их из свежего бэкапа. Проверил ядро - не обновил ли и его, затерев мои патчи. Ядро не трогал, пощадил.
Хорошо относительно вовремя заметил - только сутки прошли.
Стал бояться композера еще больше, чем раньше. Кто-нибудь в состоянии объяснить логику его поступков?

Аватар пользователя ivnish ivnish 2 февраля 2021 в 11:38

marassa wrote: зачем-то сбросил до исходного состояния .htaccess и robots.txt

Видать сработал скаффолд. У тебя древний composer-drupal-project или современный core-recommended?

Аватар пользователя marassa marassa 2 февраля 2021 в 12:50

А леший его знает - что поставилось вместе с друпалом, то и стоит. Вот начало composer.json:

    "name": "drupal/legacy-project",
    "description": "Project template for Drupal 8 projects with composer following drupal/drupal layout",
    "type": "project",
    "license": "GPL-2.0-or-later",
    "homepage": "https://www.drupal.org/project/drupal",
    "support": {
        "docs": "https://www.drupal.org/docs/user_guide/en/index.html",
        "chat": "https://www.drupal.org/node/314178"
    },
    "repositories": [
        {
            "type": "composer",
            "url": "https://packages.drupal.org/8"
        }
    ],
    "require": {
        "composer/installers": "^1.2",
        "drupal/core-composer-scaffold": "^8.8",
        "drupal/core-project-message": "^8.8",
        "drupal/core-recommended": "^8.8",
        "drupal/core-vendor-hardening": "^8.8"
    },
Аватар пользователя marassa marassa 2 февраля 2021 в 15:02

Так я с самого начала говорю, что сайт не на композере. Сам композер стоит от провайдера, а composer.json, подозреваю, с дистрибутивом ядра такой приходит. Что в нём написано я и не смотрел до сегодняшнего дня Wink

Аватар пользователя ivnish ivnish 2 февраля 2021 в 15:15

А, сорян, читал твой пост невнимательно Pardon Но я частенько в такие проекты ставлю drush и никогда проблем не было. В любом случае, бэкап сделать никогда не помешает)