Не могу установить Drupal 7.26 вопрос об установке на Open Server

Аватар пользователя Eviton Eviton 4 марта в 22:01

Делаю на локалке Open Server x64

вот скрин с версиями модулей
создаю базу данных
заливаю drupal в папку domains/testsite
начинается установка с выбором профиля и языка


и потом начинает ругаться
Unicode library Error
Multibyte string input conversion in PHP is active and must be disabled. Check the php.ini mbstring.http_input setting. Please refer to the PHP mbstring documentation for more information.

мол типа "Конвертация вывода мультибайтовых строк в PHP сейчас включена, но должна быть отключена. Проверьте настройку mbstring.http_input в php.ini. Подробности Вы сможете найти в документации по PHP."
на версии drupal 7.69 такого нет

Комментарии

Аватар пользователя Selpi Selpi 4 марта в 22:32

Собственно, все что нужно в ошибке сказано, нужно поправить php.ini для апача и сделать так:
mbstring.http_input = pass
mbstring.http_output = pass

Аватар пользователя bsyomov bsyomov 5 марта в 10:06

У вас эти параметры сейчас закомментированы, так, на всякий случай. Но всё равно ставить 7.26, да и что-то отличное от последней версии ядра, конечно не нужно.

Также, конфиг может быть не тот - посмотрите с помощью phpinfo(), какой именно у вас php в контексте веб сервера сейчас, на самом деле, и где его конфиги.

Аватар пользователя ivnish ivnish 4 марта в 22:38

Такое древнее ядро нужно ставить на php 5.6. Почему именно 7.26? Ставьте свежую версию ядра.

Аватар пользователя ivnish ivnish 4 марта в 22:42

Ну дак мы поможем. А ставить древнюю, уязвимую версию это не выход. IMCE пробовали вместо elfinder?

Аватар пользователя Eviton Eviton 4 марта в 22:47

ivnish wrote:
Ну дак мы поможем. А ставить древнюю, уязвимую версию это не выход. IMCE пробовали вместо elfinder?

IMCE не пробовал, не знаком с ним, elfinder как то привычнее что ли
Просто вот сейчас поставил 7.59 и получилось подружить файловый менеджер и редактор, а с 7.69 я вот честно два дня мучался, так и не смог, тогда подскажите пожалуйста с чего начать, раз уж 7.69?

Аватар пользователя ivnish ivnish 4 марта в 22:47

Начните с того же самого и напишите что именно не работает на ядре 7.69. Будут конкретные проблемы, будут и решения этих проблем