Почему движок Drupal так поступает с JS?

Аватар пользователя ako28 ako28 9 марта в 12:53

Всем привет. Есть ресурс, на котором понадобилось вставить виджет.
Проблема в том, что если его вставлять непосредственно в шаблон tpl.php, то он работает.
Но если его вставить в текстовое поле движка (с полной поддержкой js и html), то он не работает.
Я получаю ошибку:
Widget settings parse error: SyntaxError: Unexpected token < in JSON at position 0
Других ошибок, кроме адблока (отключение не помогает) в консоли нет

Пробовал:

  • Использовать разные версии Jquery
  • Менять местами загрузку скриптов
  • Выводить часть скрипта в html.tpl
  • Выводить скрипт в другом (чистом) типе материала

Листинг виджета


<div class="tradingview-widget-container">
  <div class="tradingview-widget-container__widget">div>
  <div class="tradingview-widget-copyright"><a href="https://ru.tradingview.com/symbols/FX-EURUSD/" rel="noopener" target="_blank"><span class="blue-text">Курс EURUSDspan>a> от TradingViewdiv>
  <script type="text/javascript" src="https://s3.tradingview.com/external-embedding/embed-widget-single-quote.js" async>
  {
  "symbol": "FX:EURUSD",
  "width": 350,
  "locale": "ru"
}
  script>
div>

Какие есть мысли? Думаю что какой-то скрипт конфликтует с этим, ведь если вставлять напрямую в шаблон, то скрипт работает.

0 Thanks

Лучший ответ

Аватар пользователя gun_dose gun_dose 9 марта в 15:34
2

Попробуйте создать формат вообще без обработки.

Комментарии

Аватар пользователя ako28 ako28 9 марта в 13:00
itcrowd72 wrote:

Но если его вставить в текстовое поле движка

Эт где такое?

=) Типы материалов - Управление полями - Создать поле - Длинный текст(Текстовая область) - формат Full HTML

Аватар пользователя ako28 ako28 9 марта в 13:37

Извините, но это вроде ошибка форума. В коде сообщения вот так

а выводится на форуме без закрывающих тэгов

Аватар пользователя ako28 ako28 9 марта в 15:23

да, причем есть виджет с того же сервиса и он работает. Я уже думал что есть конфликт двух виджетов, попробовал ну пустой странице - результат тот же.

Аватар пользователя Semantics Semantics 9 марта в 15:33

И всё же, судя по вставленному коду - у вас не хватает одного закрывающего div, смотрел то, что вы вставили в топик при создании ноды

Аватар пользователя ako28 ako28 9 марта в 17:29
1

Хотел бы я иметь мозг как у Вас! Это сработало!

В старом формате резало веджет единственная галочка, на которую я не обращал внимания - "Исправлять неправильный и обрезанный HTML"

Спасибо большое за Вашу помощь!