CKeditor оказался под запретом РКН

Аватар пользователя WillWe WillWe 15 февраля в 13:39

Конечно, понимаю, что оффтоп, тем не менее:
До вчерашнего дня нормально всё было, сегодня смотрю - ckeditor перестал открываться. Оказалось нет доступа к файлу http://cdn.ckeditor.com/4.5.4/full-all/ckeditor.js
Я даже позвонил провайдеру, узнать в чем же дело, на что мне поведали, что этот ресурс заблокирован РНК по ip адресу! Я ушам своим не поверил, пошел на сайт РКН и что же мы видим:
ping cdn.ckeditor.com

Обмен пакетами с m3r8p2r4.stackpathcdn.com [151.139.128.10] с 32 байтами данных:
Ответ от 151.139.128.10: число байт=32 время=93мс TTL=57

От 15 года еще действует эта хрень! Правда до местного провайдера добралась только сегодня видимо!
Ну и дела!!!

0 Thanks

Лучший ответ

Аватар пользователя ivnish ivnish 15 февраля в 13:50

Да, установите CKeditor локально и проблема будет решена

Комментарии

Аватар пользователя VasyOK VasyOK 15 февраля в 13:44

А что если закачать сам CKEditor в соотв папку в libraries тоже работать не будет?

Аватар пользователя WillWe WillWe 15 февраля в 18:46

В общем путём эксперимента выяснилось, что к тому модулю, что на друпале подходит не всякий скедитор (или как это сказать грамотнее я не знаю). Короче, так или иначе, работают только версии "стандартные". Полные не открываются, ошибки в скриптах какие то. Ни 4.5.4 ни новая.
На новой версии, которая сейчас на сайте, можно собрать кастомный скедитор. Однако сколько я ни добавлял плагинов к версии стандарт - кроме justify ничего добавить не удалось! Да и justify (кнопки выравнивания текста) - не отображает пиктограммы этих кнопок, но хоть и на том спасибо. Размер шрифта, Цвет текста - всё это остаётся недоступно....

Аватар пользователя VasyOK VasyOK 15 февраля в 14:07

А можно ссылку, на сайт органа, который эти поставновления выписывает. Просто интересно на чем у них сайт сделан. А то так ПХП заперетят.

Аватар пользователя VasyOK VasyOK 15 февраля в 14:50

Пусть jquery запретят.
На свой сайт они данную бибилиотеку закачали, а не подгружают извне.

Аватар пользователя WillWe WillWe 15 февраля в 15:35

Блин, еще бы разобраться, какая там библиотека то ему нужна... Не все подходят почему то.
Тот модуль использовал 4.5.4 из CDN. Нашел такую же. Версия фул не подходит! Ошибки и не открывается.
Из свежих версий (с сайта скедитора) Фул тоже не работает. Правда работает стандарт - ну а толку, там половины нужного нет!

Аватар пользователя WillWe WillWe 15 февраля в 19:01

Если не трудно, ссылочку на архив желаю. Мож у меня какая-то глючная версия попалась. Да ну хотя.... стандарт то работает. и 4.5.4 и новая. Больше никаких изменений в модуле не требовалось? только в либрари залить и всё? Ну путь ясное дело поменять в глобальных настройках... может еще чего нужно...

Аватар пользователя ivnish ivnish 15 февраля в 19:06

А формат ввода стоит Full HTML или аналог? В filtered html много чего режется, даже изображения

Аватар пользователя WillWe WillWe 15 февраля в 19:09

Да, фулл стоит. он уже настроен как надо. и с CDN отлично работает. Но вот стоит библиотеку закачать на сервер - всё. даже не открывается (только стандарт версии, а там не все плагины)