Удалились 3 изображения с хостинга

Аватар пользователя ako28 ako28 24 января в 15:31

Здравствуйте.
D7, apache 2.4, php 7.2., modsecurity
Перед сном залил статью, изображения были.
Утром их нет. Посмотрел журнал ошибок, там ничего, кроме
Во время попытки генерирования производного изображения в public://styles/content_574/public/inline/images/1.png исходное изображение public://inline/images/1.png не найдено.
Оно и понятно, превью не может сделаться, .т.к. исходника в папке нет.

Полез на сервер. (debian 9)
auth.log - все чисто, логинился только я и мой ip
в syslog, там только

Jan 24 09:55:47 vps drupal: https://site.com|1548312947|image|185.85.163.219|https://site.com/sites/default/files/styles/content_574/public/inline/im...|https://site.com/node/55|0||Source image at public://inline/images/1.png not found while trying to generate derivative image at public://styles/content_574/public/inline/images/1.png.
Jan 24 09:55:47 vps drupal: https://site.com|1548312947|page not found|185.85.163.219|https://site.com/sites/default/files/styles/content_574/public/inline/im...|https://site.com/node/55|0||sites/default/files/styles/content_574/public/inline/images/1.png

в error.log ничего с этим связанного

куда копать? ядро обновляется как только выходит новое, бэкапы каждый день

0 Thanks

Лучший ответ

Комментарии

Аватар пользователя ako28 ako28 24 января в 17:16

One Click Upload для BUEditor textareas в тело статьи.
Изображения были и ошибок не было при загрузке. В опубликованом материале они отображались сегодня ночью.

Аватар пользователя ako28 ako28 24 января в 18:08
itcrowd72 wrote:

https://www.drupal.org/project/ocupload/issues/2886006
https://www.drupal.org/project/ocupload/issues/2788645
https://www.drupal.org/project/ocupload/issues/2552157
Мейнтейнер не может воспроизвести этот баг. А без этого его не исправить

Спасибо большое! А я уж думал хостинг или вирус засел.

У меня за 8 мес. использования модуля ни разу такого не было.
А случилось это у второго админа сегодня ночью. Он заливал изображения с очень, очень и очень медленного интернета. А на утро после cron она и дропнулась. Может быть дело в интернете, что по каким-то причинам модуль пометил картинку временной ($file->status = 0;) из-за очень долгой загрузки...