Апдейт с Drupal 8 альфы до последней версии

Аватар пользователя Old Human Old Human 16 февраля 2016 в 13:12

В свое время сделал на Drupal 8 alpha(4) сайт с парой сотней статей, сейчас хочу апгрейдиться до релизной версии Drupal 8.
Update.php не работает, не хватает таблиц в базе данных, видимо очень сырая альфа была.
Возможно ли перенести материалы из старой базы данных с сохранением их путей (модуль Path в ядре, это самое главное) в новую установку Drupal 8 ?

Комментарии

Аватар пользователя Old Human Old Human 16 февраля 2016 в 15:08

Как попробовать то? ) Вручную очень не хочется, хоть как-то автоматизироваться: таблицу node из базы скопировать или еще что?

Аватар пользователя Studio VIZA Studio VIZA 16 февраля 2016 в 16:25

Old Human wrote:

Для восьмерки

Сорри, видел что 8-ка, а в процессе поиска вылетело как-то из головы.

Аватар пользователя g78knl6cvxf0 g78knl6cvxf0 17 февраля 2016 в 2:55

Old Human wrote:

В свое время сделал на Drupal 8 alpha(4) сайт

Красавчик, чо
Old Human wrote:
Update.php не работает

этот update даже между альфа версиями ломается, куда уж до релизной. Даже тулзу специальную пилили, но для знатоков, вот так все непросто.
Old Human wrote:

Для восьмерки таких нет

Модуль миграции уже в составе восьмерки (нужно только включить), но там мышкой тоже не нащелкаешь.
Можешь посмотреть среди модулей импорта/экспорта. Например Deploy или Entity Pilot.

Можно попробовать перенести в лоб, скопировав нужные таблицы и файлы-конфиги (по названиям или через /admin/config/development/configuration и там вкладки import/export). Если не получится, создать аналогичную структуру (с такими же названиями полей) и перенести только данные.

Раз сайт все это время был на альфа-4, то не горит, а значит развлекайся-нехочу Smile

Аватар пользователя Old Human Old Human 17 февраля 2016 в 11:46
1

Quote:
попробуй через драш обновиться

Быстрее будет руками перенести, чем с ним разобраться )

Аватар пользователя Old Human Old Human 24 февраля 2016 в 14:13

Грустная вышла история. Модули Migrate UI, Deploy, Entity Pilot не устанавливаются, потому что невозможно установить зависимые модули, альфа их просто не видит в списке модулей.
Попробовал с нуля все сделать - так даже мой шаблон из-под альфы не работает в релизе. Все стили пропали.
Печаль....