Подскажите по результатам работы модуля devel

Аватар пользователя genek62 genek62 12 октября 2014 в 19:45

Добрый вечер.
Сайты начали тупить - открываются очень долго. Поставил модуль devel, подскажите что означают данные, которые он выводит:
"Executed 690 queries in 267.52 ms. Queries exceeding 5 ms are highlighted. Page execution time was 1570.08 ms. Memory used at: devel_boot()=2.72 MB, devel_shutdown()=41.45 MB, PHP peak=45.75 MB."

Я так понял, что дело тут не в Mysql, запросы шустро выполняются. Подскажите в какую сторону смотреть?

ВложениеРазмер
Иконка изображения devel.jpg203.9 КБ
0 Thanks

Комментарии

Аватар пользователя orb orb 13 октября 2014 в 10:31

Executed 690 queries in 267.52 ms. - выполнено 690 запросов в БД за 0,267 секунды (нужно походить по разным страницам, в целом 690 запросов это много, хорошо если их меньше 500 везде)
Queries exceeding 5 ms are highlighted. - ниже куча запросов и те что дольше 0,005 секунды те подсвечены
Page execution time was 1570.08 ms. - страница отрендерилась за 1,57 секунды (терпимый результат)
Memory used at: devel_boot()=2.72 MB, devel_shutdown()=41.45 MB, PHP peak=45.75 MB. - памяти потрачено около 40Мб (нормально, это может прыгать от 30мб до 96Мб при создании контента)

Аватар пользователя genek62 genek62 13 октября 2014 в 19:08

Может конечно проблема с этим не связана, но сайты начали тупить после такого вот письма от digitalocean:

«We've had to unfortunately reboot your Droplet server1 due to an issue on the underlying physical node where the Droplet runs.

We are investigating the health of the physical node to determine whether this was a single incident or systemic.

If you have any questions related to this issue, please send us a ticket. https://cloud.digitalocean.com/support

Happy coding,
DigitalOcean»

Причем физический сервер они перезагружали два дня подряд.

В чем проблема была понять не смог, пробовал восстанавливать сервер из снапшота, когда проблемы еще не было, но это не помогло. Решил в итоге создать vps в дата-центре Лондон, развернул там снапшот со старой конфигурацией, пока тьфу-тьфу-тьфу все нормально, сайты открываются как и раньше без задержек. Не знаю в чем дело, есть мысль, что канал порезали на старом vps, хотя вроде контора серьезная, не должны по идее. Если опять тупить начнут, буду переезжать на it-patrol, пусть там подороже, но всегда грамотные ребята помогут, если что случится.