Помогите с TinyMCE

Аватар пользователя prostochel prostochel 10 января 2008 в 14:56

Скачал ТinyMCE, распаковал в модули, в друпале включил поддержку в модулях и поставил доступ админу. Захожу в настройки, а там:
"Could not find the TinyMCE engine installed at modules/tinymce/tinymce/tinymce/. Please download TinyMCE, uncompress it and copy the folder into modules/tinymce/tinymce."
Проверял путь всё ок module/tinymce/tinymce
Что не так и что сделать?

Комментарии

Аватар пользователя vadbars@drupal.org vadbars@drupal.org 10 января 2008 в 15:16

Вы установили и сам TinyMCE и модуль для Drupal к нему?
Если да, то проверьте, что сам TinyMCE (не модуль к нему) установлен именно в modules/tinymce/tinymce/

Аватар пользователя Гость Гость (не проверено) 12 января 2008 в 11:14

+1
та же проблема, спасибо за подсказку!

Аватар пользователя Гость Гость (не проверено) 14 января 2008 в 15:32

Спасибо, TinyMCE получилось установить.
Возникла еще одна проблема.
При создании материала картинки вставляються, при редактировании они тоже видны, но при просмотре материала отсутствуют. Что может быть причиной и как решить?

Аватар пользователя Gans1981 Gans1981 15 января 2008 в 19:06

А я вроде все скачал - правильно поставил...но ничкакие кнопочки не редактирования не отображаются :(((

Аватар пользователя Гость Гость (не проверено) 24 февраля 2008 в 18:54

вот тоже эта проблема бъюсь не могу понять что указывать в Fields to exclude/include: и Paths to exclude/include:, а может совсем не в ту сторону копаю.

Аватар пользователя qman qman 21 мая 2008 в 21:54

как проблему решил? Использую tinymce несколько лет. с таким багом не сталкивался.

Аватар пользователя Stein Stein 30 мая 2008 в 23:01

Да тоже поставил TinyMCE, тоже нечего нет, есть только ссылка под полем текст(когда создаю материал), под этим полем есть ссылка enable rich-text , но по ней не заходит - Script Error, почему так - тоже не фтыкаю, научите плиз как сделать чтоб работало, заранее спасибо.

Аватар пользователя Stein Stein 31 мая 2008 в 11:55

Все разобрался, работает))). поставил здесь http://НАШСАЙТ/admin/settings/tinymce/edit/ в basic setup Show disable/enable rich text editor toggle: false,

Выбрал Buttons and plugins и работает, хотя все таки enable rich-text не работает.

Аватар пользователя REset2 REset2 31 мая 2008 в 13:00

да кстати почему ссылка rich-text не работает, она как я понимаю должна переключать визуальный редактор на редактор с тегами.
Очень нужная штука, но почему то у меня только Визуальный работает, по нажатию disable rich-text ошибка скрипта.

Аватар пользователя DeadAnyKey DeadAnyKey 31 мая 2008 в 21:33

Версию редактора проверьте. Насколько я помню, на Drupal 5.x версия 3 TinyMCE кривовато встаёт.

Аватар пользователя Stein Stein 2 июня 2008 в 13:28

И еще одно, почему не работает <!--break--> - оно так словом и вывводится вместо того, чтобы обрезать часть текста после него?. пришлось модуль для создания тизера скачивать.

Аватар пользователя denis_poltavets denis_poltavets 25 июня 2008 в 16:37

А вот по ходу еще вопрос. Поставил это Тини, вроде все нормально, но!!!!!!! При просмотре полной версии узла не видно НИЧЕГО!!!! То есть полностью отсутствует любой текст, картинки и вообще что угодно. Как такое может быть? На главной - видно, при редактировании - видно, а при нажатии "читать дальше" - не видно. Друпал 6.2

Аватар пользователя kodges@drupal.org kodges@drupal.org 12 декабря 2008 в 16:16

"denis_poltavets" wrote:
А вот по ходу еще вопрос. Поставил это Тини, вроде все нормально, но!!!!!!! При просмотре полной версии узла не видно НИЧЕГО!!!! То есть полностью отсутствует любой текст, картинки и вообще что угодно. Как такое может быть? На главной - видно, при редактировании - видно, а при нажатии "читать дальше" - не видно. Друпал 6.2

У меня тоже такая проблема, только появилась она почемуто после последних обновлений ядра до версии 6.8 Sad

Аватар пользователя Павел Черкас Павел Черкас 8 февраля 2009 в 15:56

Стоит Друпал 5. некоректно работал TinyMCE/ Отключил модуль, снес. Перезалил все по новой. Создал новый профиль. В итоге редактор вообще не отображается. Не работает переключатель disable rich-text. Патч, который советуют в соседней теме тоже не помог. Модуль 5.х-1.9 Редактор 3_2_1_1