[Решено] Нежелательное автосохранение материала

Аватар пользователя g78knl6cvxf0 g78knl6cvxf0 9 января 2013 в 21:38

Все было хорошо. Но пару дней назад появилась беда.

Когда в поле для изображения добавить или удалить какую-нибудь картинку - происходит автоматическое сохранение всей страницы. Причем, сообщение о сохранении появляется не в самом верху материала, а сразу над полем для вставки изображения.

Переход на Просмотр страницы не происходит, но кнопки для добавления изображения пропадают, а на попытку повторного сохранение пишет:

"Содержимое этой страницы было изменено другим пользователем, или вы уже сохранили изменения, используя эту форму. В результате ваши изменения не могу быть сохранены."

И так происходит не зависимо от того, добавлять изображение через встроенную закачку, IMCE, Advanced upload и т.д.

После чего именно такое появилось - сказать затрудняюсь (может мультиязычность?). Но вдруг кто-нибудь уже сталкивался с подобной проблемой? Или хотя бы подскажет, в каком направлении и каким способом гребсти?

РЕШЕНО:

Проблема оказалась в модуле Admin language. Есть issue с патчем.

0 Thanks

Комментарии

Аватар пользователя Chyvakoff Chyvakoff 10 января 2013 в 8:58

Мне кажется что какой то js шлет на сохранение.
А хотя может и хук какой-нибудь.
Какие модули на сайте?

Аватар пользователя g78knl6cvxf0 g78knl6cvxf0 11 января 2013 в 3:01

Chyvakoff, спасибо за отклик! Попробую сделать копию, и поотключать все подряд. Потому что модулей много, врядли так по названиям можно будет понять. Мне конечно не сложно их сюда скинуть, но не хочется напрягать других зря. Думал, может это известные грабли.

еще заметил, что если сменить тип виджета с "Изображение" на "Выбор Media файла" - то проблем при загрузке нету. Так же без проблем загружаются изображения в текстовые поля через CKEditor (IMCE).

Аватар пользователя chelwolf chelwolf 13 мая 2015 в 12:30

У меня были такие же симптомы с галереей. У меня был тип материала Галерея и там поля для фото с мультизагрузкой. Когда количество фото переваливало за 130 примерно баг проявля себя и начиналось то, о чём вы пишите. Проблема оказалось не в модуле. У меня не стоит модуля, который вам мешал.

Вот только сейчас, спустя год, разобрались в чём причина бага)) Этот баг зафиксирован тут https://www.drupal.org/node/1870014 и вот тут https://www.drupal.org/node/1565704. Т.е. если кратко резюмировать, ajax не работает при очень большой форме, а в случае со 130 фотографиями форма получается большая. В связи с этим нужно увеличить лимиты на хостинге, которые являются причиной данных багов)

Я обратился в хостинг it-patrol с этим вопросом и мне помогли, увеличив лимит до 1500

Аватар пользователя mum mum 9 мая 2016 в 8:41

такая же проблема. хостинг отказывается что либо делать. а из документа просто не удалить фото, что бы просто уменьшить количество. что делать, уважаемые?