Правильная настройка CKEdit + video_filter

Аватар пользователя timmer timmer 19 апреля 2012 в 14:25

Доброго времени суток!
Никак не получается заставить работать CKEditor и Video_filter.
Установил ckeditor (модуль, сам редактор закинул в /modules/ckeditor/ckeditor), установил video filter, в конфигурации форматов текстов добавил video filter, в настройках ckeditor подключил плагин для использования video filter.
Создаю статью, добавляю урл, сохраняю - ничего нет, под заголовком пусто.
В чем может быть проблема? Гугл внятного ответа так и не показал..(

Комментарии

Аватар пользователя molfarr molfarr 19 апреля 2012 в 14:48

Попробуйте расположить Видео фильтр первым в очереди фильтров в конфигурации форматов.

Аватар пользователя timmer timmer 19 апреля 2012 в 15:12

"molfarr" wrote:
Попробуйте расположить Видео фильтр первым в очереди фильтров в конфигурации форматов.

стоит первым...

Аватар пользователя timmer timmer 23 апреля 2012 в 9:46

Чтение документации рулит))
В доках по фильтру английским по белому написано, что после добавления фильтра в форматах текста, даже если он оказался на первом месте (до преобразования адресов в ссылки), его все равно надо вручную перетащить на это место и сохраниться. Сделал - работает!

Спасибо за участие Smile

Аватар пользователя marigolu marigolu 8 ноября 2014 в 18:38

У меня тоже такая проблема. Video Filtr при добавлении в тип материала отдельным полем работает, а вот в CKEditor кнопка видео-фильтра есть, но по нажатию ничего не происходит. При попытке вставить чего-то типа:
[video:http://www.youtube.com/watch?v=36pz4B3OQss]
на сайте в этом месте ничего не отображается.
Иллюстрация: http://c2n.me/jf4RXk

Все сделано как описано выше.
Drupal последняя версия,
CKEditor 3.6.6.2.7696
Video Filter 7.x-3.1

Помогите пожалуйста подружить CKEditor и Video Filter.

Аватар пользователя marigolu marigolu 8 ноября 2014 в 19:19

У меня в Модулях почему-то отключен CKEditor: http://c2n.me/jf6avQ
В то время как этот редактор загружен и доступен при создании профилей Wysiwyg http://c2n.me/jf6d13
Как такое возможно? У меня может что-то не так настроено?