проблемы с раскрывающимися меню

Аватар пользователя bula bula 8 ноября 2006 в 9:20

Проблемы,с раскрывающимися меню когда я нажимаю на родительское меню, меню раскрывается, а ссылка на родительском меню не работает пишет page not found. Когжа я навожу на меню выходит снизу такая сыллка http://212.154.175.5/?g=en/http://212.154.175.5/?g=en/node/39 почему такую сыллку показывает откуда он мог взять эту сыллку я прописывал http://212.154.175.5/?g=en/node/39 в чем может быть проблема

Комментарии

Аватар пользователя bula bula 8 ноября 2006 в 13:40

cпасибо тебе дан у меня вчера получилось с флэш
base_url в конфиге прописан? этог где в setting.php?

Аватар пользователя bula bula 8 ноября 2006 в 13:51

у меня в меню администрировать подменю все раскрывается даже сыллка работает на главном меню там у меня прописано admin/block а галочка Expanded не стоит ну все равно меню раскрывается и все работает в чем может быть проблема

Аватар пользователя bula bula 8 ноября 2006 в 13:59

ну вот когда я создаю меню с несколькими подменю прописываю en/node/39 и ставлю галочку Expanded тогда у меня меню и подменю остаются в раскрытом положении но сыллка на главном меню тогда работает. А когда я прописываю вместо en/node/39 http://212.154.175.5/?g=en/node/39 и не ставлю галочку Expanded у меня меню раскрывается но неработает сыллка на главном меню может ктонибудь знает

Аватар пользователя Dan Dan 8 ноября 2006 в 15:10

а префиксы en и ru, это модуль i18n? может в это модуле заковыка?
я с ним, к сожалению не работал, может кто ещё знает...

Аватар пользователя bula bula 9 ноября 2006 в 5:18

а префиксы en и ru, это модуль i18n? может в это модуле заковыка? я с ним, к сожалению не работал, может кто ещё знает…

да я думаю в этом модуле наверное люди подскажите кто столкнулся такой проблемой

Аватар пользователя Полюс Полюс 25 марта 2007 в 14:16

У меня такая трабла была когда url был с завершающим /
Люди не вздумайте на конце "алиасов-директорий" при настройке пунктов меню писать этот символ. Все меню становиться раком и не раскрывается и не работает.
Надо писать www.xxx.ru/zozo но никак не www.xxx.ru/zozo/

Expand тут ни причем.
Это просто баг такой.