Не могу разобраться с установкой, помогите...

Аватар пользователя Mistero Mistero 6 февраля 2009 в 19:12

Привет.
Столкнулся с такой проблемой - как установить друпал 6.9?
Нормального руководства нигде не нашел.

Сделал следующее.
1. скачал архив отсюда - http://www.drupal.ru/downloads
2. создал settings.php (default.settings тоже присутствует)
3. залил на фтп

при открытии сайта http://домен/install.php выдается чистая,белая страница

Что еще нужно сделать?

P.S. разные джумлы, дле, вордпрессы, битриксы и.т.д встают без проблем - а тут же.. хоть бы кто написал нормальное руководство )

Заранее всем спасибо.

Комментарии

Аватар пользователя Mistero Mistero 6 февраля 2009 в 20:12

версия Apache: 1.3.37
версия Perl: 5.8.8
путь к Perl: /usr/bin/perl
версия PHP: 4.4.4
путь к PHP: /usr/local/bin/php
версия MySQL: 4.1.20
SSH: off

Аватар пользователя Mistero Mistero 6 февраля 2009 в 21:32

там еще несколько проектов хостятся... боюсь тогда с ними проблемы могут начаться

Аватар пользователя Antoniy Antoniy 7 февраля 2009 в 12:54

Если была возможность работать на PHP 5, зачем проекты ставили с PHP 4? В ногу со временем идти лучше.

Аватар пользователя DimZoneX DimZoneX 6 февраля 2009 в 21:50

Короче у меня теже грабли , не выдержал я снес все , к дРупалу больше не притронусь , корявая инсталяция и не менее корявый двиг значит. Время жалко и помощи никакой

Аватар пользователя Antoniy Antoniy 7 февраля 2009 в 0:42

Сколько ставил Друпал - всегда получалось.
В первый раз не получилось, тогда я не знал ничего о CMS

Аватар пользователя Ветер Ветер 7 февраля 2009 в 2:06

Увеличить мемори лимит хотябы до 64мб
Взять нормальный хостинг.

Пойти лечь спать, а на утро со свежей головой попробовать снова.

Аватар пользователя DimZoneX DimZoneX 7 февраля 2009 в 1:23

5 версия пошла без заморочек Smile установил , вот теперь как руссифицировать , что за ахтунг , неужели трудно файл этот было в рар упаковать с инструкцией и путем , какой то бардак и неуважение , так нельзя .

Аватар пользователя Mistero Mistero 7 февраля 2009 в 1:27

с 5 не спорю, возможно, но имхо это недоработка-минус разработчиков, что только с php5 норм работает...

С 5 модули некоторые могут работать, но не сама основа движка.

Аватар пользователя Mistero Mistero 7 февраля 2009 в 2:09

ясно, спасибо.
получается либо 5 php, либо глючьте и шаманский бубен в руки ))
только вот почему-то все остальные движки без проблем встают... битрикс, xcms и разные популярные....

P.S. фотка понравилась ))

Аватар пользователя iT iT 7 февраля 2009 в 7:21

Предлагаю ставить вопрос ребром:

либо задаться целью установить друпал и методично выяснять, спрашивать в инструкциях, мануалах и интернете, а потом уже на форуме "в чём дело, помогите пожалуйста..."

либо

без особого желания попробовать друпал в деле остановиться перед первой же преградой и, сказав "друпал - сакс", достойно, никуда не отписывая свой праведный гнев, отправиться устанавливать что-то другое.

INDWT! : In Dries we trust!

Аватар пользователя DimZoneX DimZoneX 7 февраля 2009 в 8:05

Дело не в php 5 , потому что я ставлю на локалке в MAMP на MacOsX в настройках стоит пхп 5 , 5 версию друпала установил без проблем , 6 хоть ты убейся , щас попробую с мемори пошаманить

Аватар пользователя DimZoneX DimZoneX 7 февраля 2009 в 8:08

Чуваки и стебаться не надо , могу ткнуть в несколько примеров сайтов поддержки движков , так вот такого бардака как здесь там нет , здесь все свалено в огромную кучу

Аватар пользователя andron13 andron13 7 февраля 2009 в 12:45

Smile это не куча, а облако разных тем. ваш взгляд просто ещё не приспособлен к друпалу. он годами вырабатывается.

Аватар пользователя Mistero Mistero 7 февраля 2009 в 12:27

5 версия друпала также ставится без проблем... но 5 версию спасибо - другие движки делают тоже самое и ресурсов кушают меньше, вот и хотел посмотреть 6+, но видно пока до ума ее не доведут не судьба.

Аватар пользователя DimZoneX DimZoneX 7 февраля 2009 в 12:47

Поставил 6 версию , но без бубенов не обошлось , Lol заработала только на Денвере на Win машине , под Макинтошем ну никак не хочет

Аватар пользователя Mistero Mistero 7 февраля 2009 в 13:01

блин, вобщем проблема не в хостинге и не в php5, а в том что на этом сайте лежит кривая версия

итак.

1. установил с первого раза без проблем. качать отсюда - http://ftp.drupal.org/files/projects/drupal-6.9.tar.gz

2. Руссификация - качаем это http://drupal.ru/files/drupal-6.9-ru-translations.zip

3. Закачиваем на хост
4. В админ панели открываем модули (modules), включаем Content translation.
5. Идем в "настройки сайта" -> "языки", нажимаем добавить язык -> выбираем Русский.
6. В "языки" Русский ставим по умолчанию.

Аватар пользователя Antoniy Antoniy 7 февраля 2009 в 13:05

Шестая версия более требовательна. Можно начать работать с пятерки, если хочется посмотреть, что такое Друпал, а потом на шестерку перейти. На локалке хорошо тренироваться, если машина хорошая, а если машина не очень, то времени больше уйдет.

Мне после пятерки шестая версия показалась очень прожорливой, но потом поработал с кешем, отключил Update Status (хостинг у меня малобюджетный совсем) и не хуже пятерки теперь летает.

Аватар пользователя Mistero Mistero 7 февраля 2009 в 13:03

"Если была возможность работать на PHP 5, зачем проекты ставили с PHP 4? В ногу со временем идти лучше." - значит на то были причины Wink

Windows Vista тоже идет в ногу со временем )))

Аватар пользователя Antoniy Antoniy 7 февраля 2009 в 13:08

Ну, похоже MS теперь решили Windows Vista на Windows 7 поменять, а на PHP 5 вроде нареканий нету.

Аватар пользователя Mistero Mistero 7 февраля 2009 в 13:10

Vista была выпущенна недоработанной, в этом потом MS призналась... Windows 7, насколько я знаю также построена на ядре Vista... и по некоторым данным это как раз то, что должно была из себя представлять Vista в конечно результате...
но не успели видимо, а бабла срубить хочется с пользователей, вот и выпустили недоработку

Аватар пользователя ND ND 4 апреля 2009 в 17:43

Похожая проблема. На денвере без особых проблем установил, настроил сайт. Залил файлы на хостинг. Создал, импортировал базу данных через симпексдампер, изменил файл settings.php.
PHP ver. 5.2.5 max_input_time 60, memory_limit 32M.
При открытии index.php виден только фон. Вот код HTML

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" lang="ru" xml:lang="ru">
  <head>
    <title>www.mysite.ru</title>

    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="alternate" type="application/rss+xml" title="www.mysite.ru RSS" href="http://chicago.spaceweb.ru/~MYACCOUNT/rss.xml" />

<link rel="shortcut icon" href="/~MYACCOUNT/sites/default/files/amity_island_favicon_2.ico" type="image/x-icon" />
    <link type="text/css" rel="stylesheet" media="all" href="/~MYACCOUNT/modules/node/node.css?2" />
<link type="text/css" rel="stylesheet" media="all" href="/~MYACCOUNT/modules/system/defaults.css?2" />

<link type="text/css" rel="stylesheet" media="all" href="/~MYACCOUNT/modules/system/system.css?2" />
<link type="text/css" rel="stylesheet" media="all" href="/~MYACCOUNT/modules/system/system-menus.css?2" />
<link type="text/css" rel="stylesheet" media="all" href="/~MYACCOUNT/modules/user/user.css?2" />
<link type="text/css" rel="stylesheet" media="all" href="/~MYACCOUNT/sites/all/modules/fckeditor/fckeditor.css?2" />
<link type="text/css" rel="stylesheet" media="all" href="/~MYACCOUNT/sites/all/themes/amity_island/style.css?2" />
       
  </head>

  <body

Вобщем почему то не выполняется код <body<?php print phptemplate_body_class($left, $right); ?>>
У кого нибудь было подобное, есть какие мысли? Всё о чем прочитал в гугле и здесь, описал выше всё в норме.

Аватар пользователя ND ND 20 марта 2009 в 14:21

Короче перезалил дамп, вроде работает, но теперь чистые ссылки не работают Sad