проблема с path и pathauto после включения русского языка...

Аватар пользователя JaSs JaSs 2 декабря 2008 в 10:25

не могу понять - проблема с path и pathauto после включения русского языка.
Включил русский, alias-ы стали создаваться для "всех" или для english - не могу даже отследить, когда вылазит english
И, если синоним, создан для всех, он не работает - то есть я по прежнему вижу ссылки как /node/1 и тд. если руками исправляю на русский - включается...
как настроить, что бы сразу создавались для русского, и почему при выборе "все" не показывается для русского????
пробовал английский вообще отключить, вроде как в системе один язык.. но, все равно, создаются синонимы для "все" и не показываются...
(все модули и друпал последних версий)

Комментарии

Аватар пользователя Dimm Dimm 2 декабря 2008 в 14:03

Вроде такой же косяк появился при последнем обновлении на Pathauto 6.x-2.x-dev.
У меня вместо русских алиасов стали создаваться алиасы для english.
Буду разбираься.

Аватар пользователя Dimm Dimm 2 декабря 2008 в 14:42

Оказалось косяк не связан с обновлением Pathauto.
Я тоже сначала разрабатывал сайт на английском языке, создавал ноды, а затем добавил русский язык.
НО!
В уже созданных нодах сохранилась пременная $node->language ='en'!
Эта пременная используется при создании алиаса при обновлнии ноды.
$alias = pathauto_create_alias('node', $op, $placeholders, $src, $node->nid, $node->type, $node->language);
Переменные ноды можно просмотрть с помощью модуля devel.

Решение:
UPDATE `база`.`префикс_node` SET `language` = 'ru' WHERE `language` = 'en';

UPDATE `база`.`префикс_url_alias` SET `language` = '' WHERE `language` = 'en' ;

Аватар пользователя JaSs JaSs 15 декабря 2008 в 17:32

спасибо большое!!!!!
сменно так все и оказалось, поправил...

единственно, остался вопрос - почему при создании алиаса "для всех" языков - проблему не решало..
но, это уже вопрос философский, на будущее... ))