tinymce как правильно установить?

Аватар пользователя Гость Гость (не проверено) 23 августа 2006 в 0:01

Вообщем скачал модуль tinymce и сам движек. всё разместил как надо, разрешил зарегистрированным пользователям им пользоваться, создал профиль в нем разрешил использовать его везде.
пытаюсь создать заметку - обычное поле ввода! обьясните подробно что надо делать?
Спасибо!

Лучший ответ

Аватар пользователя lexa74 lexa74 23 августа 2006 в 18:37

ну вот!

я уж таких ошибок наловил море когда сам чего-то понатворил... )))

Комментарии

Аватар пользователя Гость Гость (не проверено) 23 августа 2006 в 1:38

вроде сделал как написано! я так понял что никакие темы править не нужно? но сам редактор не появляется! есть тока ссылка disable rich-text
под самим полем и всё((

Аватар пользователя Shedko Shedko 23 августа 2006 в 5:13

Проверьте куда Вы поместили закачанный Tiny MCE 2.0


3. Поместите папку 'tinymce' с пакетом редактора в директорию modules/tinymce. Таким образом, движок TinyMCE будет находиться в modules/tinymce/tinymce.


Когда-то сам ошибся, и не в ту папку поместил, и как итог тоже было окошко с подписью "disable rich-text" и редактор не появлялся, а также проверьте, на всякий случай, а разрешили ли Вы Себе использовать его в настройках прав.


А еще, отключите ЛЮБОЙ ДРУГОЙ редактор. например fckeditor, просто если включены оба сразу, то может мообще непонятное начаться.

Аватар пользователя Гость Гость (не проверено) 23 августа 2006 в 12:22

в том то и дело что вроде всё верно сделал! пример работает в фаерфоксе а вот в самом друпале тока строка disable rich-text под каждым полем и яваскрипт ошибка при нажатии(

Аватар пользователя lexa74 lexa74 23 августа 2006 в 12:27

управление - доступ глянь чтоб были права на использование.

ну и в профилях самого тини смотреть надо чтоб было оно по умолчанию для данных групп

Аватар пользователя Гость Гость (не проверено) 23 августа 2006 в 12:33

я разрешил для авторизированных и создал группу модератор и для них тоже разрешил! под своим админским аккаунтом вижу тока disable rich-text, добавил себе роль модератора, тоже самое... в профилях тоже разрешил...
создал модератора, захожу, там тоже тока disable rich-text. если нажать выскакивает яваскрипт эрор "предполагается наличие объекта" или типа того

Аватар пользователя Гость Гость (не проверено) 23 августа 2006 в 12:55

опа...
сменил тему на стандартную и всё заработало! но почему на spreadfirefox не пашет? никто не подскажет?

Аватар пользователя Stranger! Stranger! (не проверено) 23 августа 2006 в 17:30

ТО есть получается что придется использовать другую тему? может кто нибудь знает всё таки как это поправить?

Аватар пользователя Stranger! Stranger! (не проверено) 23 августа 2006 в 18:31

Разобрался!)

Случайно удалил print $head когда редактировал тему)
всем огромное спасибо!