Паника! Первый раз выкладываю Drupal на хостинг

Аватар пользователя Jeremic Jeremic 28 июля 2006 в 6:01

Всем привет! Я в панике!!! Выложил на хостинг, а там выдается такое...

warning: init_theme(./themes/engines/phptemplate/phptemplate.engine): failed to open stream: No such file or directory in /usr/local/psa/home/vhosts/rosres.ru/httpdocs/includes/theme.inc on line 78.
warning: init_theme(): Failed opening './themes/engines/phptemplate/phptemplate.engine' for inclusion (include_path='.:/usr/local/psa/apache/lib/php') in /usr/local/psa/home/vhosts/rosres.ru/httpdocs/includes/theme.inc on line 78.  

В папке themes есть и моя тема и engines с phptemplat'om... Буду стучаться в службу поддержки...

МОЖЕТ КТО ЗНАЕТ ЧЕМ ЛЕЧИТСЯ?? А то, я думаю, служба поддержки не любит чужие головняки решать...

З.Ы. Drupal 4.7

Комментарии

Аватар пользователя Jeremic Jeremic 28 июля 2006 в 9:05

Помоему это не влияет, т.к. если нет прав (у меня дома было), то прут совсем другие ошибки.

Аватар пользователя Гость Гость (не проверено) 28 июля 2006 в 15:49

права или регистр имен...
Дома на винде пробовал?

Аватар пользователя Jeremic Jeremic 28 июля 2006 в 18:21

Дома то конечно работает! Иначе как я его делал бы?)). Винда + Денвер, все ОК.

Аватар пользователя kiev1 kiev1 29 июля 2006 в 3:05

права файлов или путаница с большими/маленькими буквами в названиях файлов/директорий, больше ничего.

Аватар пользователя Jeremic Jeremic 30 июля 2006 в 6:54

Как то выложил)), с помощью великого админа)).
Но возникла такая фигня: Пропало отображение всех типов данных сконструированных с помощью CCK. Т.е. все создынне поля
(при создании страницы) - их нет. А при отображении, появляется только заголовок. Залез в базу данных, в таблице
node_content_мойтип есть все поля, все данные. Такая же фигня проиходит на локальной машине, если отключить модуль
content.module в CCK. Но я проверил несколько раз на хостинге он включен! В журнале Друпала нет никаких ошибок.
В чем может быть дело???

З.Ы. Что, content.module не включается?

Заранее спасибо!

Аватар пользователя Jeremic Jeremic 30 июля 2006 в 11:28

Решилось все переустановкой БД. Фиг знает что такое...
Всем, все равно спасибо.

Аватар пользователя Гость Гость (не проверено) 23 октября 2006 в 23:34

<?php // $Id: index.php,v 1.90 2006/01/27 18:51:51 dries Exp $ /** * file * The PHP page that serves all page requests on a Drupal installation. * * The routines here dispatch control to the appropriate handler, which then * prints the appropriate page. */ require_once './includes/bootstrap.inc'; drupal_bootstrap(DRUPAL_BOOTSTRAP_FULL); $return = menu_execute_active_handler(); switch ($return) { case MENU_NOT_FOUND: drupal_not_found(); break; case MENU_ACCESS_DENIED: drupal_access_denied(); break; case MENU_SITE_OFFLINE: drupal_site_offline(); break; default: // Print any value (including an empty string) except NULL or undefined: if (isset($return)) { print theme('page', $return); } break; } drupal_page_footer();

Аватар пользователя macsim macsim 29 апреля 2007 в 13:34

Так все таки, каким файлам нужно присвоить атрибут 777, а потом его снять? опишите подробнее.

Аватар пользователя ola90 ola90 30 апреля 2007 в 16:15

выкладываю сайт на 5.1 на бесплатный аккаунт на prohosts.org (потестировать). залил базу, залил папку drupal, сменил адрес базы в settings.php. а дальше что делать?

Аватар пользователя macsim macsim 5 мая 2007 в 13:57

Блин, да ответит хоть кто нибудь. У меня не получается установить Drupal русскую локализацию на nix хостинг, на Denwere дома устанавливаю, без проблем, на nix не хочет, а "англ" нормально устанавливается на nix, в чем может быть проблема, все вроде выполнил по инструкции, всем папкам и файлам дал 777, а все равно не устанавливается, если кто знает, напишите в личку. Кстати вот подтверждение мои слов, вот где устанавливаю http://blog.macsim.pp.ru/install.php как видите русский язык есть, но потом он пропадает, устанавливается часть русского и часть все по анг. не понимаю в чем загвоздка. Повторюсь что при установке на Denwer с тойже конфигурацией и набором файлов, не вызывает проблем, устанавливается в лет. В чем загвоздка, помогите разобраться.

Аватар пользователя vadbars@drupal.org vadbars@drupal.org 5 мая 2007 в 16:25

Если Drupal только частично русифицировался, то скорее всего у вас не полностью импортировался файл русского перевода. Попробуйте его импортировать заново.

Иногда это происходит оттого, что скрипт не успевает произвести загрузку за время, отведенное ему на выполнение. Оно регулируется переменными max_execution_time и max_input_time в php.ini. Если вы не итмеете доступа к этому файлу и не можете их увеличить, то попробуйте загружать русификацию помодульно (см. мою подпись).