Views: Отображение товаров без Commerce Plugin -- возможно ли? Нужна выборка по критериям

Аватар пользователя SerW SerW 13 мая в 22:57

Котаны, здорова! В общем, суть такова. Я делаю вот такое отображение основных параметров товаров (Efficiency, Lucky, Comfort, Resilience): https://stepnfilter.com/list-all.
Но это -- совсем не то, что мне нужно.

То есть, в моей выборке (которую пользователь сейчас даже не может задать :(() только лишь отображаются значения тех параметров

На самом деле, мне нужно ровно вот такое решение: https://stamps.ru/store?f[0]=format:1093&node=18131.
То есть, чтобы пользователь мог дергать ползунки и выбирать чекбоксы.
Как это все делается? Я знаю6 что Друпал именно под это заточен ))

Важное уточнение: у меня последний Восьмой Друпал, и поэтому в нем нет модуля Коомерс.
Если я поставлю 9-ый Друпал + Коммерс -- решит ли это проблему? И все равно, дайте ссылок на руководства, плиз! : ))

Комментарии

Аватар пользователя VasyOK VasyOK 15 мая в 21:47

SerW wrote: чтобы пользователь мог дергать ползунки и выбирать чекбоксы.
Как это все делается?

Это делается мышкой через search_api + facets. Через раскрытые фильтры views вроде бы тоже возможно, но надо разбираться в народном творчестве и программировать самому.
Руководства - на Ютюбе вбить: "drupal search api facets"

Восьмой Друпал, и поэтому в нем нет модуля Коомерс.
Если я поставлю 9-ый Друпал + Коммерс -- решит ли это проблему?

Есть под 8ку Комерц. Лучше обновлять сайт до 9ки. Это делатеся также, как и переход между минорными версиями. Бекап файлов и БД делаем в любом случае.
Надеюсь понимаете, Комерц - это для торговли, а фасеты могут фильтровать как товары Комерца так другие сущности.

Аватар пользователя SerW SerW 16 мая в 22:37

VasyOK, а вот скажите, пож., как нужно устанавливать Друпал 9 + эти плагины и commerce через Composer?

Аватар пользователя VasyOK VasyOK 17 мая в 1:37

Для начала нужно весь сайт пересобрать через Composer. Т.е. установить все модули через него и дать сайту рабочую БД - должно заработать если правильно сделаете. По ssh с сайтом можете соединиться? Вбить composer --version - что выдает?

А потом уже вбить в консоли строку установки модуля $ composer require 'drupal/commerce:^2.30' - написано на старнице каждого модуля. Не надо бояться этого. Собтвенно я сам кликбилдер.

Аватар пользователя SerW SerW 17 мая в 8:40

Дак вот у меня не тронутая инсталляция 9-ки:
$ composer --version

In ArrayLoader.php line 44:

Unknown package has no name defined ([{"name":"asm89\/stack-cors","version"
:"1.3.0","version_normalized":"1.3.0.0","source":{"type":"git","url":"https
:\/\/github.com\/asm89\/stack-cors.git","reference":" , и так далее, очень много красного текста! ((