Версия сервера базы данных 10.1.38-MariaDB-0+deb9u1 меньше, чем минимальная требуемая версия 10.3.7

Аватар пользователя Valeratal Valeratal 17 октября в 14:02

Решил поставить 9-ку

И вот
Версия сервера базы данных 10.1.38-MariaDB-0+deb9u1 меньше, чем минимальная требуемая версия 10.3.7

Казалось бы, хостинг довольно свежий. А верия МарииДБ старая

И почему Мария, а не обычный МySQL

Нашел инфу https://searchengines.guru/ru/forum/1007459

дык еще надо поэтапно апгрейдить эту самую МариюДБ и делать бекапы...

Странно, 8-ка туда вставала нормально

Комментарии

Аватар пользователя ivnish ivnish 17 октября в 15:58

Используй нормальные, проверенные хостинги для друпала. Я лично как минимум два могу порекомендовать: радон и таймвеб (рефералки лень писать)

Аватар пользователя Valeratal Valeratal 17 октября в 16:12

ivnish wrote: Используй нормальные, проверенные хостинги для друпала

Меня вполне устраивает текущий хостинг.
Радон, это ж шаред, не?
у радона мария старая, там 9-ка также не пойдет
MariaDB 10.2.x указана https://www.ra-don.ru/hosting

Да и вообще, у них походу нет аренды сервера

ну и вообще, кто пойдет хостится к этому агрессивному челу? Я не пойду

да в целом это тупо, хостинг менять из-за неподходящей версии базы данных

Аватар пользователя ivnish ivnish 17 октября в 16:18

А тебе не шаред нужен? VPS что ли? Тогда в чем вопрос, поставь любую версию.

У радона всё прекрасно идёт, в том числе и девятка

Кто агрессивный? 🤔

Не тупо, а логично

Аватар пользователя Valeratal Valeratal 17 октября в 16:20

у меня аренда сервера

У радона всё прекрасно идёт, в том числе и девятка

я рад за его хостящихся

Кто агрессивный?

Дубовский

Аватар пользователя bsyomov bsyomov 17 октября в 19:23

Релиз Mariadb 10.1 вышел в 2014году, и это практически ещё mysql 5.5. У этого релиза был просто очень долгий срок поддержки, но он кончился, прям сегодня. Smile Это реально очень устаревшая версия.

Апгрейд между версиями будет работать, с очень большой вероятностью. Каждую следующую нет смысла ставить, это обычно, не уменьшает вероятность проблем. Но конечно всегда надо бекапиться перед этим.

Почему D9 хочет прям 10.3.7 не очень понятно. Должен бы и с 10.2.х веткой работать.

Ну и Debian должен быть уже 10, конечно - он и так довольно консервативен. Smile
А треды на сёрче не стоит серьёзно воспринимать, в плане администрирования. Уровень этой тематики там крайне низок, и часто просто дичь пишут, прям как про СЕО... Smile

Аватар пользователя Valeratal Valeratal 18 октября в 16:52

Короче, все не так просто. Или просто. Пока не понял

Дело в том ,что у меня ISP-менеджер. А там родную базу обновлять не рекомендуется. Может сломаться сама панель. Но можно поставить свежую Марию в качестве альтернативной. То есть создать еще один SQL-сервер. Вроде так будет норм