Решение проблемы с обновлением Image Effects 2 > 3 Not supported!

Аватар пользователя mozh mozh 8 июля в 12:00

Столкнулся c такой вот штукой:

Not supported! Error
Image Effects 8.x-2.0
Recommended version:8.x-3.0

Если вы обновляете сразу на 3-ю версию, то не сможете сделать drush updb

composer require drupal/image_effects:^3.0

получите

The installed version of the Image Effects module is too old to update. [error]
Update to an intermediate version first (last removed version: 8203, installed version: 8201).

В итоге вам нужно обновиться до последней 2.* версии, сделать updb и только потом обновляться на 3-ю версию и снова делать updb
После долгих мучений с зависимостями пришел к такому:

composer require drupal/imagemagick:^2.7 --update-with-dependencies
composer require drupal/image_effects:^2.3 --update-with-dependencies
vendor/drush/drush/drush updb

composer require drupal/image_effects:^3.0 drupal/imagemagick:^3.1 drupal/file_mdm --update-with-dependencies
vendor/drush/drush/drush updb

ну конечно же на прод, stage, dev будем деплоить по два раза.
И в конце концов мне захотелось посмотртеть что же в тех обновлениях второй версии:

/**
* Clear caches to discover new effects.
*/
function image_effects_update_8202() {
// Empty function.
}

/**
* Clear caches to discover new effects.
*/
function image_effects_update_8203() {
// Empty function.
}

Shok
В общем обновился успешно, но этого прикола не понял совсем, обсудим?

Комментарии

Аватар пользователя adano adano 8 июля в 13:33

Чего тут обсуждать... Там комплекс проблем в свое время и с convert, и с gm, и с их версиями, и версиями php. Потом все это решилось.
А вы просто воспроизвели все эти "танцы с бубном" около Друпала.
Поздравляю с "ачивкой"!