Как поставить Drupal Commerce Demo на Open Server? Проблема с sqlite.

Аватар пользователя VasyOK VasyOK 16 ноября в 12:14

Пытаюсь поставить Drupal Commerce Demo (вроде это Kickstart) отсюда https://github.com/drupalcommerce/demo-project
Выполняю

composer create-project drupalcommerce/demo-project demo-commerce --stability dev --no-interaction
cd demo-commerce
php scripts/quickstart

после этого выдает:
[ERROR] You must have the pdo_sqlite PHP extension installed. See core/INSTALL.sqlite.txt for instructions.

Ввиду того что, пользуюсь подсистемой Линукс для Виндовс попробовал:
sudo apt-get install php-sqlite3
выполнил - не помогло

Проверил OSPanel\modules\php\PHP-7.1\php.ini:
НЕ закоментировано:
extension=php_sqlite3.dll
extension=php_pdo_sqlite.dll

0 Thanks

Лучший ответ

Аватар пользователя VasyOK VasyOK 17 ноября в 16:42

php -v
выдало

PHP 7.3.8-1+ubuntu18.04.1+deb.sury.org+1 (cli) (built: Aug  7 2019 09:52:12) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.8, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.8-1+ubuntu18.04.1+deb.sury.org+1, Copyright (c) 1999-2018, by Zend Technologies

Делее:
sudo apt-get install php7.3-sqlite3 - вроде поставилось. Не знаю был ли тут при чем sudo apt update или нет.

Пробую снова:
php scripts/quickstart
3/18 [▓▓▓▓░░░░░░░░░░░░░░░░░░░░░░░░]
Verify requirements
In install.core.inc line 2288:
BC Math:
Commerce requires the BC Math PHP extension. - облом

Набираю
sudo add-apt-repository ppa:ondrej/php
sudo apt update
sudo apt install php7.3-bcmath

Потом опять:
php scripts/quickstart - все работает.

Всем спасибо!

А где эта БД находится? В текстовом файле? Я сборку установил, чтобы понять что и как, но наверняка кто-то будет пробовать делать магазины прямо на этой сборке. Насколько это корректно?

Комментарии

Аватар пользователя VasyOK VasyOK 16 ноября в 22:42

Не помогает.
Вроде бы вебсервер (который Open Server) работает независимо от того, где я команды ввожу (ConEmu и Ubuntu для Windows).

Аватар пользователя voviko voviko 17 ноября в 10:38
1

тоже решил заценить, в итоге таже ошибка (debian 9)
apt-get install php-sqlite3 ставит php7.3-sqlite3
apt-get install php7.0-sqlite3 исправляет
Короче ставить надо под текущую версию php

Аватар пользователя VasyOK VasyOK 17 ноября в 15:43

Не получается Sad
Ввожу
sudo apt-get install php7.0-sqlite3
выдает:

vasyok@DESKTOP-HN6EA56:~$ sudo apt-get install php7.0-sqlite3
[sudo] password for vasyok:
Reading package lists... Done
!>Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  php7.0-common
The following NEW packages will be installed:
  php7.0-common php7.0-sqlite3
0 upgraded, 2 newly installed, 0 to remove and 5 not upgraded.
Need to get 923 kB of archives.
After this operation, 4852 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Err:1 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php7.0-common amd64 7.0.33-10+ubuntu18.04.1+deb.sury.org+1
  404  Not Found [IP: 00.000.00.00 80]
Err:2 http://ppa.launchpad.net/ondrej/php/ubuntu bionic/main amd64 php7.0-sqlite3 amd64 7.0.33-10+ubuntu18.04.1+deb.sury.org+1
  404  Not Found [IP: 00.000.00.00 80]
E: Failed to fetch http://ppa.launchpad.net/ondrej/php/ubuntu/pool/main/p/php7.0/php7.0-common_7.0.33-10+ubuntu18.04.1+deb.sury.org+1_amd64.deb  404  Not Found [IP: 00.000.00.00 80]
E: Failed to fetch http://ppa.launchpad.net/ondrej/php/ubuntu/pool/main/p/php7.0/php7.0-sqlite3_7.0.33-10+ubuntu18.04.1+deb.sury.org+1_amd64.deb  404  Not Found [IP: 00.000.00.00 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

php scripts/quickstart - все так же не запускается

Аватар пользователя ivnish ivnish 17 ноября в 15:45
1

sudo apt update сделай.

А вообще не видишь что ли, что он не может пакеты скачать? У тебя какая-то со связью проблема.

Аватар пользователя VasyOK VasyOK 17 ноября в 16:15

sudo apt update

Reading package lists... Done
Building dependency tree
Reading state information... Done
117 packages can be upgraded. Run 'apt list --upgradable' to see them.

Аватар пользователя VasyOK VasyOK 17 ноября в 16:42

php -v
выдало

PHP 7.3.8-1+ubuntu18.04.1+deb.sury.org+1 (cli) (built: Aug  7 2019 09:52:12) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.8, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.8-1+ubuntu18.04.1+deb.sury.org+1, Copyright (c) 1999-2018, by Zend Technologies

Делее:
sudo apt-get install php7.3-sqlite3 - вроде поставилось. Не знаю был ли тут при чем sudo apt update или нет.

Пробую снова:
php scripts/quickstart
3/18 [▓▓▓▓░░░░░░░░░░░░░░░░░░░░░░░░]
Verify requirements
In install.core.inc line 2288:
BC Math:
Commerce requires the BC Math PHP extension. - облом

Набираю
sudo add-apt-repository ppa:ondrej/php
sudo apt update
sudo apt install php7.3-bcmath

Потом опять:
php scripts/quickstart - все работает.

Всем спасибо!

А где эта БД находится? В текстовом файле? Я сборку установил, чтобы понять что и как, но наверняка кто-то будет пробовать делать магазины прямо на этой сборке. Насколько это корректно?