Какие модули PHP5.6 надо устанавливать для Drupal 6?

Аватар пользователя maxim_al maxim_al 7 августа в 9:33

Надо поднять виртуальную копию вебсервера, и для этого надо поставить Drupal6, mysql5.6 и PHP5.6.
Какие модули PHP надо устанавливать?
Для установке на более поздние drupal-ы ставится PHP7.2 и для него находил какие модули надо (вопрос конечно интересный, на сколько те "инструкции" корректны/полны/исчерпывающи...)
Вот был такой перечень:
php72 php72-mysqli mod_php72 php72-mbstring php72-zlib php72-curl php72-gd php72-json

Прошу подсказать.

0 Thanks

Комментарии

Аватар пользователя gun_dose gun_dose 7 августа в 10:37

Скорее всего меньше, т.к. многие из модулей, которые были в ядре 5.6, в седьмых версиях нужно ставить отдельно.

Аватар пользователя sas@drupal.org sas@drupal.org 7 августа в 18:39
1

Как только начнете ставить друпал, если чего не будет хватать получите ошибку с описанием, того что надо установить. В весте или хампе проблем нет, по умолчанию достаточно. А вообще если ставили и знаете пых 7.2 то для дру 6 https://github.com/d6lts/drupal

Аватар пользователя maxim_al maxim_al 8 августа в 0:57
<a href="mailto:sas@drupal.org">sas@drupal.org</a> wrote:

А вообще если ставили и знаете пых 7.2 то для дру 6 https://github.com/d6lts/drupal

нет, пытался ставить по неким инструкциям...
А что за ссылка, что та за друпал, какой то форк заточенный для php7?

Аватар пользователя maxim_al maxim_al 9 августа в 1:16

А "Long Term Support" это не официальный Drupal LTS или официальный? На их сайте я что-то такого не встречал

Аватар пользователя maxim_al maxim_al 9 августа в 1:34

Что-то мне не понятно.
В официальном репозитории дистриб прекращён обновляться в 2016 году.
Далее якобы LTS есть от "партнёров", но если пойти со страницы https://www.drupal.org/project/d6lts на все релизы и выбрать 6.х то тут ничего нет... https://www.drupal.org/project/d6lts/releases?api_version%5B%5D=87
И как тогда связан код дистрибутива https://github.com/d6lts/drupal с официальным кодом?..
Какой то не привычный для меня вариант.
Сама компания Drupal проверяет этот код как-то?

Аватар пользователя marassa marassa 9 августа в 6:42
maxim_al wrote:

Сама компания Drupal проверяет этот код как-то?

"Компании Drupal" не существует в природе.

Аватар пользователя maxim_al maxim_al 22 августа в 4:06

Скажите а если drupal 6 lts можно далее будет обновить на новые версии (последовательно или как-то иначе)?

Аватар пользователя maxim_al maxim_al 26 августа в 1:27

А вот вопрос, если к примеру в 6.38 стоит модуль CCK, я поверх D6.38 залил d6LTS и в том списке модулей есть модуль CCK. - Как его "установить", так же просто записать поверх того что было в 6.38?
Т.е. правильно я понимаю что процесс перехода на lts заключается в копировании поверх существующего модулей из раздела lts?

Аватар пользователя maxim_al maxim_al 26 августа в 1:51
maxim_al wrote:

А вот вопрос, если к примеру в 6.38 стоит модуль CCK, я поверх D6.38 залил d6LTS и в том списке модулей есть модуль CCK. - Как его "установить", так же просто записать поверх того что было в 6.38?
Т.е. правильно я понимаю что процесс перехода на lts заключается в копировании поверх существующего модулей из раздела lts?

Вопрос почему возник, в исходной базе используется модуль ctools но вот его папку на сервере сайта найти не получается. Вот и думаю может всё же как то иначе ставится?
Если всё же надо просто копировать то как найти в какой папке находится этот установленный модуль?

Аватар пользователя sas@drupal.org sas@drupal.org 26 августа в 8:56

- сделать архив сайта
- залить lts и нужные модули, несли чего то не видно гляньте папку модуля в system таблице
- запустить update.php
- Протестировать нужный функционал

Аватар пользователя maxim_al maxim_al 26 августа в 9:56
<a href="mailto:sas@drupal.org">sas@drupal.org</a> wrote:

- запустить update.php

Хм ошибка Parse error: syntax error, unexpected '&' in */modules/counter/counter.install on line 185
а в той строке:
db_add_index(&$ret, 'counter', 'counter_date', array('counter_date'));

а апдейт точно надо? - ведь я модули те же самые использую.

Аватар пользователя maxim_al maxim_al 26 августа в 9:59

И ещё, сайт вроде запустился, но в контенте такие вот ошибки (набор разный и по количеству и по содержимому):
The selected file /tmp/file0iyAJe could not be copied. tmpcss/default/advagg_css/css_33a4c03672615ceabe2b1a4d740bb8bc_0.css
The selected file /tmp/filevWgA3d could not be copied. tmpcss/default/advagg_css/css_b45a1491dca59b864b3e7d018df6dacb_0.css
The selected file /tmp/fileDyjqp8 could not be copied. tmpcss/default/advagg_css/css_eba249098ef864d6248f19b75c1daa2e_0.css
The selected file /tmp/fileTD8BDh could not be copied. tmpcss/default/advagg_css/css_f050df1e9ab350b06cdaf52dc8bc832a_0.css
The selected file /tmp/filehtLhq3 could not be copied. tmpcss/default/advagg_js/js_a54822ea3ea1f1d302c5af5bb105f436_0.js
The selected file /tmp/fileMWdyX3 could not be copied. tmpcss/default/advagg_js/js_cd2a6776e8d6c63d9179bd44b3eb637b_0.js
The selected file /tmp/fileWYcPKX could not be copied. tmpcss/default/advagg_js/js_f9843c12c4a351f5f355d749f362012f_0.js
The selected file /tmp/filectKRG1 could not be copied. tmpcss/default/advagg_js/js_35ecf331aac42075fcccd85e6869dd36_1.js

Аватар пользователя maxim_al maxim_al 27 августа в 8:47

В общем проблема была не в правах а во владельце... отключал модуль - ошибка пропадала, включал снова появлялась, и в /tmp куча файлов. Пофиксил вопрос с владельцем www:wheel на папки с друпалом и файлами сайта - и эта ошибка ушла.

Аватар пользователя maxim_al maxim_al 27 августа в 8:52

Теперь проблема с модулем ImageAPI ImageMagick.
Изначально стал ругаться на то что нет /usr/local/bin/convert.
Я ему его перебросил, ругаться перестал но с фотогалереей все равно не полноценно сайт работал.
Добрался в модуль смотрю там есть проверка версии:
/usr/local/bin/convert -version
Запускаю в консоли и вижу ошибку:
ld-elf.so.1: Shared object "libMagickCore.so.5" not found, required by "convert"
И вот что-то не пойму как это победить.

Аватар пользователя maxim_al maxim_al 27 августа в 9:06

да, без него вообще не работала фотогалерея.
Теперь работает но не конвертирует, когда разворачивает в окно.

Аватар пользователя maxim_al maxim_al 27 августа в 15:03

Там да, есть gd, но работает или также как magick... Нашел на гитхабе пакет magick-а, начал пытаться установить, но что-то не пошло. Какие-то ошибки пошли. Завтра попробую с этим разобраться.

Аватар пользователя maxim_al maxim_al 28 августа в 8:45

Переключил на gd и о чудо - галерея нормально работает...
Получается что ImageMagick вообще не нужен? Какие-то преимущества у него перед GD есть?

Аватар пользователя sas@drupal.org sas@drupal.org 28 августа в 8:53
1

IMHO ImageMagick определенно является более популярной и известной библиотекой, и вы, вероятно, найдете больше поддержки, примеров и сценариев для нее. Также я сомневаюсь, что различия в производительности действительно будут иметь значение в большинстве случаев использования — по моему опыту за последние десять лет, IM не самая быстрая, но и не самая медленная из библиотек обработки графики и идеально подходящая для большинства повседневных задач.
примеры см. library of thousands of examples

GD простой и железобетонный, IM красочней по выходу и на него много модулей под Drupal с большим разнообразием функций и возможностей.

Аватар пользователя ivnish ivnish 27 августа в 9:08

Это уже серверная сторона. Видимо, неправильно установили ImageMagick. Переустановите пакеты

Аватар пользователя maxim_al maxim_al 27 августа в 9:14
ivnish wrote:

Это уже серверная сторона. Видимо, неправильно установили ImageMagick. Переустановите пакеты

Хм, вот это я очень примерно понимаю, но только совсем не понимаю как. Попробовал гуглить но как то не удачно
# whereis ImageMagick
ImageMagick:
Пусто, в портах его нет...

Аватар пользователя maxim_al maxim_al 28 августа в 8:49

Блин, просто как оказалось пакет называется "pecl-imagick".
Сейчас собирается в портах, но что-то здоровый. Куча настроек при конфигурации. Соберётся проверю - работает или нет.

Аватар пользователя ivnish ivnish 29 августа в 10:23

В нормальных дистрибутивах всё уже собрано до нас. Меняйте фряху на дебиан ;)

Аватар пользователя maxim_al maxim_al 2 сентября в 2:50

К сожалению в данном случае не мне решать, есть некая стратегия руководства.
Хотя я бы и сам на CentOS подался...

Аватар пользователя maxim_al maxim_al 6 сентября в 4:18

Решил попробовать на CentOS, с надеждой что тут всё получится и использовать это как аргумент...
Но что-то вообще странное происходит, система ругается на то что не может записать файлы, типа нет прав...

Каталог ../www-files закрыт для записи.
Каталог ../www-files/tmp закрыт для записи.

при этом ls -l даёт вывод о полных правах!

[www-files]# ls -l | grep tmp
drwxrwxrwt. 5 root apache 149 сен 5 18:38 tmp

Кем блин этот drupal тут пытается работать?

Аватар пользователя maxim_al maxim_al 6 сентября в 9:17

Может чего не правильно понимаю...
В общем.
Сделал /etc/httpd/conf.d/mysite.conf
в нем прописал пути к сайту: /var/www/html/sites/mysite
так как исходный сайт уже есть то делаю по аналогии - рядом /var/www/html/sites/mysite-files
Владельцев делал по разному и root:root и ya-user:apache и apache:apache
При этом права уже в конце вообще сделал 777 и на /var/www/html/sites/mysite и на /var/www/html/sites/mysite-files.
Всё это рекурсивно и права и владельца (хотя с учётом 777 - какое это имеет значение-то???)
Захожу в настройки в друпале /администрирование / файловая система - там говорится - директории закрыты на запись

Каталог ../mysite-files закрыт для записи.
Каталог ../mysite-files/tmp закрыт для записи.

ну и другие ошибочки...
Похожие описанным выше по freebsd - но там я решил проблему сменой владельца, а тут вообще ничто никак не решается.
И главное, если tmp указываю корневой - на это перестаёт ругаться, хотя права и владельца делаю такого же.
Вот что не так делаю?

Аватар пользователя ivnish ivnish 6 сентября в 9:28

Переключите апач в режим mpm itk

Я рекомендую создать нового пользователя и разместить веб-рут в его домашнем каталоге, например /home/user/www. ТMP каталог укажите в конфиге виртуального хоста /home/user/tmp Ну и естественно на все каталоги и файлы должны быть права user:user, а не root, apache и прочие

Аватар пользователя maxim_al maxim_al 6 сентября в 9:37
ivnish wrote:

Переключите апач в режим mpm itk

Подробнее можно? Как сделать и что это даст?

Аватар пользователя ivnish ivnish 6 сентября в 9:39

Подробности можно узнать в поисковых системах. Самое время начать их использовать.

и что это даст?

Это даст возможность запускать каждый виртуальный хост от указанного пользователя. Так же каждый виртуальный хост будет изолирован друг от друга, что дает огромный плюс к безопасности

Аватар пользователя maxim_al maxim_al 6 сентября в 9:41

это мне совершенно не нужно. Я не хостер. Свой сервер, свой сайт. Ничьих других там не будет

Аватар пользователя maxim_al maxim_al 6 сентября в 9:40

И да, какая разница где (в какой папке) располагается сайт - главное права/владельцы... всегда так было, зачем в хом это убирать?

Аватар пользователя ivnish ivnish 6 сентября в 10:58

Я советую как лучше и как правильно исходя из многолетнего опыта. А прислушиваться к советам или нет, это уже дело ваше.

Аватар пользователя maxim_al maxim_al 9 сентября в 1:40

Есть мысли почему на CentOS у меня проблемы с работой Drupal с файловой системой (ниже описано)?