Ошибка при установке нового сайта на друпал

Аватар пользователя d2889im d2889im 9 июня в 17:00

Странная ошибка после установки друпал на хостинг, прикрепляю скриншот ошибки

0 Thanks

Лучший ответ

Аватар пользователя d2889im d2889im 9 июня в 19:30

А все позвонил на горячую линию устранили ошибку, обновили до версии 7.1 и все заработало

Комментарии

Аватар пользователя marassa marassa 9 июня в 17:33
1

Самое главное, ни в коем случае не говорите какую версию Drupal Вы ставите, какая версия PHP на сервере, и полный текст сообщения об ошибке тоже не приводите, а то вдруг станет видно в каком именно файле произошла ошибка, и станет совсем неинтересно гадать.

Аватар пользователя Semantics Semantics 9 июня в 18:08

Восьмёрка это, а вот пхп, видимо, какой-нить 5.3.
Раз это ник.ру, то у них ещё беда, что надо в панели управления включать нужные расширения PHP, от mbstring до bcmath.

Дело раскрыто

Аватар пользователя d2889im d2889im 9 июня в 17:48

Регистрировался на сайте nic.ru и них купил доменное имя и у них установил на хостинг друпал. Какая там версия и PHP не знаю. Прикрепил ещё один скриншот

Аватар пользователя marassa marassa 9 июня в 18:30

https://www.drupal.org/project/drupal/issues/2942186
Похоже, Вы ставите версию Друпал ниже 8.5, а версия PHP на хостинге 7.2. Один вопрос: зачем Вам эта версия Друпал? Вы отдаете себе отчёт, что Ваш сайт на этой версии Друпал станет не Вашим через несколько дней, если не часов после его появления в сети?

Аватар пользователя marassa marassa 9 июня в 18:49

Была похожая история с reg.ru. Если совсем коротко - деньги вернули ;)
Большинство больших "универсальных" хостингов декларирует поддержку всех мыслимых CMS, а на деле в состоянии поддерживать разве что ВордПресс с битриксом. Остальные лежат в виде дистрибутивов давно скомпрометированных версий двухлетней давности, внятная техподдержка отсутствует в принципе. Возможно, у них есть какие-то преимущества , если сам готов все ставить и решать все вопросы, но для начинающих это совсем не вариант.

Аватар пользователя d2889im d2889im 9 июня в 18:53

Обновить его до последнего нельзя или заново переустанавливать новую версию?

Аватар пользователя marassa marassa 9 июня в 19:10

Теоретически можно, только в процессе выяснится, что у них не стоят ни drush, ни composer, а вот их установить самому на шареде уже не получится. Постепенно придет понимание, что нужно уходить на специализированный хостинг, ну или на VPS, но там уже придется быть самому себе сисадмином со всеми вытекающими.

Аватар пользователя marassa marassa 9 июня в 19:18

Спасибо, буду знать. Но на специализированном друпал-хостинге они просто уже стоят, и никаких доп. танцев с бубном не нужно.

Аватар пользователя d2889im d2889im 9 июня в 19:30

А все позвонил на горячую линию устранили ошибку, обновили до версии 7.1 и все заработало

Аватар пользователя marassa marassa 9 июня в 19:37
1

PHP не обновили, а наоборот откатили назад, чтобы древняя уязвимая версия Друпал могла работать. Типичное "решение" для большого хостера. Когда сайт взломают (а это вопрос очень недолгого времени) они скажут, что они тут ни при чем.

Аватар пользователя d2889im d2889im 9 июня в 21:36

Все равно обновлять буду до 8 версии. Только непонятно почему теоретически обновление только возможно. А кто может обновить?

Аватар пользователя marassa marassa 10 июня в 12:37

Разговор становится чем дальше, тем страннее...

d2889im wrote:

Все равно обновлять буду до 8 версии

Что именно? PHP? 8-ую версию не написали ещё... Drupal? У Вас и так 8-ая версия, только не последний релиз.

d2889im wrote:

Только непонятно почему теоретически обновление только возможно

Потому что или получится, или нет. В принципе можно и ручками, без драша и композера.

d2889im wrote:

А кто может обновить?

Тот, кто умеет...