Drupal 6.19 и PHP-7

Аватар пользователя Sarah Sarah 10 мая в 22:01

Добрый день!

По ряду причин вынуждены использовать версию Друпал 6,19. Апгрейд не рассматривается.

Встала задача апгрейда php до версии 7.

ВОПРОС: работает ли версия Drupal 6.19 на php7?
Если нет - то какая максимальная версия php возможна?

Заранее спасибо!

0 Thanks

Комментарии

Аватар пользователя ivnish ivnish 10 мая в 22:13

Официально нет. Но даже если ядро будет работать, ещё есть и контрибные модули. Вот они могут и не работать, т.к. давно все заброшены.

https://stackoverflow.com/questions/44403451/is-drupal-6-is-compatible-w...

https://www.mydropwizard.com/blog/drupal-6-year-2020-and-php-7-support

Аватар пользователя veligursky veligursky 11 мая в 9:33
ivnish wrote:

Официально нет. Но даже если ядро будет работать, ещё есть и контрибные модули. Вот они могут и не работать, т.к. давно все заброшены.
https://stackoverflow.com/questions/44403451/is-drupal-6-is-compatible-w...
https://www.mydropwizard.com/blog/drupal-6-year-2020-and-php-7-support

ну как бы по вашей даже ссылке
https://www.mydropwizard.com/blog/announcing-drupal-645-and-selected-con...

Аватар пользователя ivnish ivnish 11 мая в 10:10

Эта компания поддерживает Д6 своими силами и это считается "неофициально", потому что это не Аквия

Аватар пользователя veligursky veligursky 11 мая в 11:40
ivnish wrote:

Эта компания поддерживает Д6 своими силами и это считается "неофициально", потому что это не Аквия

Это не имеет значения, топик стартеру нужны не "шашечки", а чтобы работало на РНР7.

Аватар пользователя VasyOK VasyOK 11 мая в 9:36

Даже если есть причины (кстати какие?), по которым сидите на 6-ке, нужно обновить хотя бы до последней версии по ветке.
Официально - это drupal 6.38 https://www.drupal.org/drupal-6.38-release-notes
Неофициально - качаем тут https://github.com/d6lts.
Там же скачиваете новые неофициальные версии модулей. Обращайте внимание, что у нмногих модулей (views например) есть даже внутри ветки свои подветки - 6х-2х и 6х-3х. В конце жизненного цикла 6-ки использовалась чаще 6х-3х, но т.к. у вас 6.19 - я не знаю.

PHP - https://github.com/d6lts/drupal - в неоф. релизе пишут, что поддерживается, но кроме ядра есть масса молулей. А они уже могут и не поддерживать. Так что попробуйте версию 5.3. Если не получится - 5.2. А потом уже на php 7 переключите и проверите.

Аватар пользователя Semantics Semantics 11 мая в 11:36

Drupal 6 на PHP 7 это что-то из области фантастики.

И скорее всего, стоимость всего этого действа будет не только выше отдельного хостинга со старой версией PHP, но даже больше стоимости апгрейда на D8

Аватар пользователя veligursky veligursky 11 мая в 11:45
Semantics wrote:

Drupal 6 на PHP 7 это что-то из области фантастики.
И скорее всего, стоимость всего этого действа будет не только выше отдельного хостинга со старой версией PHP, но даже больше стоимости апгрейда на D8

Смотрим ссылки выше и тогда говорим о фантастике. А вот на счет стоимости апгрейда - это уже ОЧЕНЬ спорный момент.

Аватар пользователя Semantics Semantics 11 мая в 11:48

Смотрим ссылки выше и узнаем, что это ядро и пятёрка самых популярных модулей.
Не думаю, что автор ограничивается только ими.
Во времена шестого друпала бывали проекты где по 200+ модулей стояло.

Аватар пользователя veligursky veligursky 11 мая в 12:48
Semantics wrote:

Смотрим ссылки выше и узнаем, что это ядро и пятёрка самых популярных модулей.
Не думаю, что автор ограничивается только ими.
Во времена шестого друпала бывали проекты где по 200+ модулей стояло.

Ответ автору топика дан. Все остальное офтоп и гадание на кофейной гуще.

Аватар пользователя elia elia 12 мая в 11:55

Я еще более крутой некрофил, чем автор, но хочу полностью вылечиться :)

Имеем: D5 на PHP 5.2.17 + MySQL 5.6 + Debian 7.
Хочу перейти на D8 + PHP ... + MySQL 5.6 (5.7) + Debian 9
Есть ли какой-то roadmap совместимости версий всего этого комплекса? Что бы я мог понять что и в какой последовательности обновлять?

Сторонних модулей минимум, самые критичные два и они написаны мной, поэтому им переделку сделаю.
Для исключения лишних вопросов: PHP 5.2.17 на Debian 9 собрать не возможно.
Спасибо за совет.

Аватар пользователя ivnish ivnish 12 мая в 11:56

Начать нужно с обновления Д5 на Д6. А с Д6 уже можно сделать миграцию на Д8 стандартным модулем migrate, который входит в состав Д8

Аватар пользователя elia elia 12 мая в 12:08
ivnish wrote:

Начать нужно с обновления Д5 на Д6. А с Д6 уже можно сделать миграцию на Д8 стандартным модулем migrate, который входит в состав Д8

Подойдет любой D6.x?
А какой максимальный D6.x будет работать на PHP 5.2.17? D6.24, кажется, уже отказывается проводить обновление сайта на этой версии PHP - минимум PHP 5.3 требует. [А может подправить установочные скрипты, чтобы не ругался. Если для обновления не используются критичные функции. А в каком месте скрипт править?]

Правильно ли я понимаю следующий процесс обновления:
1. Обновить сайт на текущем сервере до D6.x
2. Собрать заранее виртуалку на Debian 9 + PHP 7.x
3. Перенести файлы сайта + БД на новые сервер из п.2 и дальше идти с помощью модуля migrate?

Аватар пользователя ivnish ivnish 12 мая в 12:13

Начните с последней версии Д6. Я давно не работал с Д6, поэтому сложно сказать будет он на PHP 5.2 работать или нет.

Правильно ли я понимаю следующий процесс обновления:

Да, для миграции сайт на Д6 не обязательно должен работать (а на PHP 7 он вряд ли заработает без патчей). Мигратору нужна будет только его БД и загруженные файлы

Аватар пользователя Semantics Semantics 12 мая в 13:52

У вас стоит задача апгрейда своими силами?
Просто перенос контента это правда не самое сложное в переходе на версию выше

Аватар пользователя elia elia 12 мая в 14:05
Semantics wrote:

У вас стоит задача апгрейда своими силами?
Просто перенос контента это правда не самое сложное в переходе на версию выше

Все дело в тех самописных модулях - это наполнение страниц специфическим сервисом и backend, ради которого сайт и существует в настоящее время, по сути дела.
Сейчас сайт базируется на двух dedicated servers и надо расти дальше. Просто давным-давно был написан начальный вариант одного из модулей под D5, а потом, спустя много лет, прояснились перспективы развития и пошел настолько взрывной рост, что не хватало времени и сил на своевременный апгрейд платформ. А сейчас уперся в тупик на системном уровне (основная проблема - безопасность и надежность), и надо делать качественный скачок на уровне платформ.

Аватар пользователя elia elia 13 мая в 10:14

Так главные модули все равно надо писать заново. На фоне этой задачи апгрейд сайта с D5 на D8.x - это один из самых малых вопросов. ;) Зато именно при апгрейде и последующем тестировании результатов будет прекрасно видно, что нужно править или переписывать заново, а что можно оставить старым.

Аватар пользователя ivnish ivnish 13 мая в 10:16

Хорошо, что вы понимаете необходимость апгрейда) С Д8 у вас столько возможностей откроется, что прям "ууух" )