Кто пользуется d6lts? Есть нюансы?

Аватар пользователя VasyOK VasyOK 13 апреля в 11:27

Кто пользуется https://github.com/d6lts? Есть нюансы?

Есть несколько сайтов "без притензий" на D6. Работают и ладно. Бюджета на апгрейд у них нет.

0 Thanks

Комментарии

Аватар пользователя VasyOK VasyOK 14 апреля в 18:22

Поставил работает.
Нюансы:
1) Непривычно видеть в Доступных обновлениях фразу
Drupal core 6.49 Обновление системы безопасности: 6.38

2) Если модуль имеет нсколько версий, по умолчанию на гитхабе показана более старая. https://github.com/d6lts/views/ - тут по умолчанию 2х, хотя можно выбрать и 3х.

3) Не нравится, что папка модуля в скачиваемом архиве имеете название views-6.x-3.x, а не views.

Можно с этим как-то Драш заставить работать?

Аватар пользователя sas@drupal.org sas@drupal.org 15 апреля в 9:47

1) для этого и lts чтобы поддерживать по безопасности
2) Дело в совместимости с экосистемой, некоторым нужен 2, некоторым - 3
P.S.
Для безопасности надо использовать PHP 7.2 и бывает код надо рефакторить для совместимости.