Создание панелей

Аватар пользователя viktorbeznosov viktorbeznosov 11 февраля в 17:22

Друзья, появилась проблема.
Я создал содержимое-панель http://joxi.ru/82QNe57HjQ1EEA.
Тип builder.
Но когда я пытаюсь добавить новый регион или хоть что-то изменить - вылетает сообщение, "Вы не авторизованны"
http://joxi.ru/YmE0yDki04Z8Lr
Почему так происходит? Кэш чистил - не помогает. Выходил и снова заходил

0 Thanks

Комментарии

Аватар пользователя gun_dose gun_dose 12 февраля в 9:45

Модуль jQuery Update установлен? Попробуйте для админки поставить стандартную версию jQuery

Аватар пользователя viktorbeznosov viktorbeznosov 12 февраля в 10:06

Модуль jQuery Update установлен.
Везде установлен jquery по умолчанию http://joxi.ru/krD0qD9iEPg7lr
Но дело в том, что когда я создавал новую тему. В файле my_theme.info я подключаю скрипт scripts[] = assets/js/main.js
и при этом мне в консоли вылезает ошибка http://joxi.ru/L21dWbjU87z9Jm.
Если я подключаю нужные библиотеки jquery в файле my_theme.info http://joxi.ru/Vrw9YlQiOljE12 тогда эта ошибка исчезает,
но зато начинается вот такая вакханалия при заполнении панели содержимым http://joxi.ru/12MNejQHMVwzyA
Как можно еще безболезненно для Drupal подключить нужные мне библиотеки jquery ?

Аватар пользователя sas@drupal.org sas@drupal.org 12 февраля в 15:10

Скрипты могут использовать разные версии jQuery , об это написано в них, once например живет уже отдельно, если надо использовать на одной странице скрипты совместимые с разными версиями jqeury, можно попробовать выбрать максимальную и заюзать https://github.com/jquery/jquery-migrate или адаптировать скрипты (см. F12 + console)