Некоторые текущие обновления не могут быть выполнены из-за отсутствия необходимых зависимостей.

Аватар пользователя vlucas vlucas 14 мая 2018 в 21:59

При обновлении базы данных выходит предупреждение:

Некоторые текущие обновления не могут быть выполнены из-за отсутствия необходимых зависимостей.

Где можно посмотреть более конкретно каких зависимостей не хватает?

Спасибо!

Лучший ответ

Аватар пользователя vlucas vlucas 15 мая 2018 в 11:55

Решено:
Отдебажил class DbUpdateController увидел:

domain_access module cannot be updated. It contains an update numbered as 8000 which is reserved for the earliest installation of a module in Drupal 8.x, before any updates. In order to update domain_access module, you will need to install a version of the module with valid updates.

т.е. что-то с обновлениями domain_access. буду смотреть дальше.
Большое спасибо @Semantics за наводку

Комментарии

Аватар пользователя vlucas vlucas 14 мая 2018 в 22:58

ребят, да нет там ничего, нигде нет...в статусе:
ОБНОВЛЕНИЯ БАЗЫ ДАННЫХ
Актуально

вообще в статусе ни одной ошибке, только 1 варнинг о том что экспериментальный модуль Place Blocks включен

Аватар пользователя loup54 loup54 15 мая 2018 в 1:33

Какие модули установлены? После обновления модуля предупреждения о куки, нужно зайти и явно ссылку ему указать на страницу конфиденциальности, а то у него там <front> прописано обновить базу не получается. Точно не помню, но есть еще что то похожее с модулем связано

Аватар пользователя fairrandir fairrandir 15 мая 2018 в 2:09

Великолепный ответ. А главное - подходит практически к любому вопросу на форуме.

Аватар пользователя loup54 loup54 15 мая 2018 в 2:16

Вполне нормальный ответ, сам сталкивался с подобной проблемой, смысл в том, что сайт в порядке и беспокоится не о чем, выше я написал, что в частности дает такой результат

Аватар пользователя vlucas vlucas 15 мая 2018 в 11:55

Решено:
Отдебажил class DbUpdateController увидел:

domain_access module cannot be updated. It contains an update numbered as 8000 which is reserved for the earliest installation of a module in Drupal 8.x, before any updates. In order to update domain_access module, you will need to install a version of the module with valid updates.

т.е. что-то с обновлениями domain_access. буду смотреть дальше.
Большое спасибо @Semantics за наводку