Как решить проблему с composer drupal-update?

Аватар пользователя vitaboss

Всем привет! Подскажите если кто знает, как решить проблему. Делаю это и что-то пошло не так?

# composer drupal-update
> Drupal\composer_manager\Composer\Command::update
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- The requested package drupal/entity 1.x-dev exists as drupal/entity[7.1.0, 7.1.0-alpha1, 7.1.0-alpha2, 7.1.0-alpha3, 7.1.0-alpha4, 7.1.0-alpha5, 7.1.0-alpha6, 7.1.0-beta1, 7.1.0-beta10, 7.1.0-beta11, 7.1.0-beta2, 7.1.0-beta3, 7.1.0-beta4, 7.1.0-beta5, 7.1.0-beta6, 7.1.0-beta7, 7.1.0-beta8, 7.1.0-beta9, 7.1.0-rc1, 7.1.0-rc2, 7.1.0-rc3, 7.1.1, 7.1.2, 7.1.3, 7.1.4, 7.1.5, 7.1.6, 7.1.7, 7.1.8, 8.0.1, 8.1.0-alpha1, 8.1.0-alpha2, 8.1.0-alpha3, 8.1.0-alpha4, dev-7.x-1.x, 7.1.x-dev, dev-8.x-0.x, 8.0.x-dev, dev-8.x-1.x, 8.1.x-dev] but these are rejected by your constraint.
Problem 2
- The requested package drupal/entity_reference_revisions ~1.0 exists as drupal/entity_reference_revisions[8.1.0, 8.1.0-rc1, 8.1.0-rc4, 8.1.0-rc6, 8.1.0-rc7, dev-8.x-1.x, 8.1.x-dev] but these are rejected by your constraint.
Problem 3
- The requested package drupal/inline_entity_form ~1.0 exists as drupal/inline_entity_form[7.1.0, 7.1.0-beta1, 7.1.0-beta2, 7.1.0-beta3, 7.1.0-beta4, 7.1.0-rc1, 7.1.1, 7.1.2, 7.1.3, 7.1.4, 7.1.5, 7.1.6, 7.1.7, 7.1.8, 8.1.0-alpha1, 8.1.0-alpha2, 8.1.0-alpha3, 8.1.0-alpha4, 8.1.0-alpha5, 8.1.0-alpha6, 8.1.0-beta1, dev-7.x-1.x, 7.1.x-dev, dev-8.x-1.x, 8.1.x-dev] but these are rejected by your constraint.
Problem 4
- The requested package drupal/profile 1.x-dev exists as drupal/profile[8.1.0-alpha1, 8.1.0-alpha2, 8.1.0-alpha3, 8.1.0-alpha4, 8.1.0-alpha5, dev-8.x-1.x, 8.1.x-dev] but these are rejected by your constraint.
Problem 5
- The requested package drupal/state_machine ~1.0 exists as drupal/state_machine[7.1.0-beta1, 7.1.0-beta2, 7.2.0, 7.2.0-alpha1, 7.2.0-alpha2, 7.2.0-alpha3, 7.2.0-beta1, 7.2.0-beta2, 7.2.0-beta3, 7.2.0-beta4, 7.2.0-beta5, 7.2.0-beta6, 7.2.1, 7.2.2, 7.2.3, 7.2.4, 7.2.5, 7.2.6, 7.3.0-beta1, 8.1.0-beta1, 8.1.0-beta2, 8.1.0-beta3, dev-7.x-1.x, 7.1.x-dev, dev-7.x-2.x, 7.2.x-dev, dev-7.x-3.x, 7.3.x-dev, dev-8.x-1.x, 8.1.x-dev] but these are rejected by your constraint.

Спасибо.

Версия Drupal:
0 Thanks

Комментарии

Аватар пользователя multpix
multpix 1 год назад

Привет, а опубликуй содержимое своего composer.json.
Думаю вся проблема в запрашиваемых версиях модулей.

Аватар пользователя vitaboss
vitaboss 1 год назад

Привет, дружище!!! Уже спасибо!!!
Вот оно чё было:

{
"name": "drupal/commerce",
"type": "drupal-module",
"description": "Drupal Commerce is a flexible eCommerce solution.",
"homepage": "http://drupal.org/project/commerce",
"license": "GPL-2.0+",
"require": {
"drupal/core": "~8.2",
"drupal/address": "~1.0",
"drupal/entity": "8.1.0-alpha4", вот тут
"drupal/entity_reference_revisions": "8.1.0-rc7", тут
"drupal/inline_entity_form": "8.1.0-beta1", тут
"drupal/profile": "8.1.0-alpha5", тут
"drupal/state_machine": "8.1.0-beta3", и здесь
"commerceguys/intl": "~0.7",
"ext-bcmath": "*"
},
"minimum-stability": "dev"
}

только что прописать этакое, чтоб на следующие версии не ругалось.

Аватар пользователя multpix
multpix 1 год назад

composer create-project drupal-composer/drupal-project:~8.2 drupal --stability dev --no-interaction
Остальное все require
composer require drupal/commerce

Такой получился:

{
    "name": "drupal-composer/drupal-project",
    "description": "Project template for Drupal 8 projects with composer",
    "type": "project",
    "license": "GPL-2.0+",
    "authors": [
        {
            "name": "",
            "role": ""
        }
    ],
    "repositories": [
        {
            "type": "composer",
            "url": "https://packages.drupal.org/8"
        }
    ],
    "require": {
        "composer/installers": "^1.2",
        "drupal-composer/drupal-scaffold": "^2.2",
        "cweagans/composer-patches": "~1.0",
        "drupal/core": "~8.0",
        "drush/drush": "~8.0",
        "drupal/console": "~1.0",
        "drupal/address": "^1.0@RC",
        "drupal/commerce": "^2.0@beta",
        "wikimedia/composer-merge-plugin": "^1.3",
        "drupal/entity": "^1.0.0 ",
        "drupal/profile": "^1.0.0 "
    },
    "require-dev": {
        "behat/mink": "~1.7",
        "behat/mink-goutte-driver": "~1.2",
        "jcalderonzumba/gastonjs": "~1.0.2",
        "jcalderonzumba/mink-phantomjs-driver": "~0.3.1",
        "mikey179/vfsStream": "~1.2",
        "phpunit/phpunit": "~4.8",
        "symfony/css-selector": "~2.8"
    },
    "conflict": {
        "drupal/drupal": "*"
    },
    "minimum-stability": "dev",
    "prefer-stable": true,
    "autoload": {
        "classmap": [
            "scripts/composer/ScriptHandler.php"
        ]
    },
    "scripts": {
        "drupal-scaffold": "DrupalComposer\\DrupalScaffold\\Plugin::scaffold",
        "pre-install-cmd": [
            "DrupalProject\\composer\\ScriptHandler::checkComposerVersion"
        ],
        "pre-update-cmd": [
            "DrupalProject\\composer\\ScriptHandler::checkComposerVersion"
        ],
        "post-install-cmd": [
            "DrupalProject\\composer\\ScriptHandler::createRequiredFiles"
        ],
        "post-update-cmd": [
            "DrupalProject\\composer\\ScriptHandler::createRequiredFiles"
        ]
    },
    "extra": {
        "installer-paths": {
            "web/core": ["type:drupal-core"],
            "web/libraries/{$name}": ["type:drupal-library"],
            "web/modules/contrib/{$name}": ["type:drupal-module"],
            "web/profiles/contrib/{$name}": ["type:drupal-profile"],
            "web/themes/contrib/{$name}": ["type:drupal-theme"],
            "drush/contrib/{$name}": ["type:drupal-drush"]
        }
    }
}

И нормально идет
composer update

Аватар пользователя vitaboss
vitaboss 1 год назад

Спасибо!!!