Drupal 8

Аватар пользователя mozh mozh 20 октября 2015 в 9:16

Попытка познакомиться с Drupal 8 закончилась неудачей(((
Значит при первом запуске на openserver у меня стоит php 5.3 и apache 2.2 получаю ошибку:
Parse error: syntax error, unexpected '[', expecting ')' in E:\OpenServer\domains\drupal8\vendor\guzzlehttp\promises\src\functions.php on line 41
Начинаю гуглить ничего не нахожу. После смотрю системные требования php 5.6 и apache 2.4. Меняю версии в openserver и получаю ошибку отсутствия файла msvcr100.dll. Начинаю копать дальше, ставлю какие-то библиотеки C++ с оф сайта майкрософт, и теперь получаю ошибку "Ошибка при запуске приложения (0x000007b). Для выхода из приложения нажмите кнопку ОК".
Что делать?

Комментарии

Аватар пользователя Tkhorev Tkhorev 28 декабря 2015 в 15:51

Я на хостинге джино.ру получил только что это:
Parse error: syntax error, unexpected '[', expecting ')' in /home/users/t/tesmon/domains/XXX.XXX.ru/vendor/guzzlehttp/promises/src/functions.php on line 41
Тоже знакомство не удалось...

Чуть позже:
О! Да тут всё быстро решается самостоятельно)
Большая картинка: http://www.drupal.ru/files/field/comment_node_blog/2015-12-12_00-55-00_s...

Аватар пользователя Tkhorev Tkhorev 12 декабря 2015 в 19:33

Ну релиз же...
А модули... мне может и коробочного функционала хватит, супер-пупер порталы не делаю.
Самое важное в моём случае, это не иметь в дальнейшем проблем с обновлением системы )

Аватар пользователя tlito tlito 28 декабря 2015 в 17:41

надо большими буквами писать

для работы друпал 8 нужен php 5.6 или выше.


но если ниже, то вы будете иметь ошибки

Аватар пользователя leo7 leo7 29 января 2017 в 14:17

в Open Server не смог подобрать вариант ниже, чем апач 2.4, вот и пытаюсь уточнить
Что на Орге ставят точки после 2..., видел. Так и не понял: можно на 2.2, или будут траблы..?

Аватар пользователя multpix multpix 29 января 2017 в 14:53

Если у вас проблемы с пониманием как это работает (и вы на винде),
то начните с оригинальной коробки: https://docs.acquia.com/dev-desktop
(есть все что нужно)
а продакшн отдайте сисадмину.

Я же - использую встроенный пыховый сервер (для dev) или nginx.

Аватар пользователя leo7 leo7 29 января 2017 в 15:02

я на винде, понимания нет,но я и есть админ, я и веду продакшн.
(попытки, многократные, найти админа за 7 лет ни к чему не привели).

Решаю сейчас задачу инсталляции сервера, для перехода сайтов, вот и пытаюсь понять: что за затык с апачем.
В опен сервер есть апач 2.2, и апач 2.4.И есть сочетания, которые в нём, т.е в ОС, не поднимаются.
Например, 64бит вообще не запускаются, хотя пробую на Open Server x64

Пока вижу, что только апач 2.4 ОС согласен сочетать с нужными версиями пхп и мускула..
если б прошло на 2.2., было б меньше проблем.

Аватар пользователя leo7 leo7 31 января 2017 в 12:58

PHP Version 5.6.30 удалось натянуть на 7, апач 2.4, MySQL(i) 5.5.52-MariaDB
были проблемы с доступом к файлам,
Хостеры сказали:
«перевели веб -сервер на режим itk, что должно решить указать указанные вами ошибки.
Так же вернули права на директории 775 и 664 на файлы. При этом ошибок доступа не наблюдаем»

я так понял, это что-то мне ослабит в надёжности?
теперь буду пробовать шагнуть в 8