Проблемы с русификацией

Аватар пользователя Yanus Yanus 28 июня 2005 в 0:31

У меня друпал 4.3.1. Ламерский вопрос - где в админ панели я могу загрузить эти самые .по файлы? Мне только предлагает переводить построчно...

--
Nick: прикрепил файлик с локализацией для 4.4.

ВложениеРазмер
Двоичные данные locales_4_4_sql_utf8_v6_3_(2004_06_17).tar.bz2117.7 КБ

Комментарии

Аватар пользователя Nick_ Nick_ (не проверено) 28 июня 2005 в 18:47

В 4.3 po файлы не поддерживаются.
Локализация для 4.3 у меня где-то дома валялась в виде дампа таблицы locales.
Правда, не знаю на сколько полная.
Если надо, поищу, когда домой приду ?

А, вообше, может Вам обновиться до более акткальной версии?

Аватар пользователя Yanus Yanus 29 июня 2005 в 2:03

Хм... Поставил последний 4.4 (4.5 и выше хостер не поддерживает из-за старого ПХП), и все равно нету нужной кнопки... Если вы будете так добры, Ник, я бы очень хотел заполучить эту табличку.

Аватар пользователя Yanus Yanus 30 июня 2005 в 0:59

...Но теперь вылазит новая ошибка при попытке обновить список блоков:

user error: Unknown column 'throttle' in 'field list'
query: UPDATE blocks SET region = 0, status = 0, custom = 0, path = '', weight = 0, throttle = 0 WHERE module = 'node' AND delta = '0' in /home/ivancher/public_html/includes/database.mysql.inc on line 97.

Что бы это значило?

Аватар пользователя Yanus Yanus 30 июня 2005 в 15:47

Прогнал, даже что-то ручками в базу подобавлял, что оно мне сказало. И фиг с ней с ошибкой, но я, чтоб русифицировать навигационное меню, блок Navigation отключил, а теперь блок Навигация включить не дает :(...

Аватар пользователя Nick Nick 30 июня 2005 в 16:01

Вы посмотрите в дапме БД, который идет с 4.4, как там определено поле throttle таблицы blocks и руками ALTER эту таблицу и добавте туда это поле.
Если возникнуть проблемы, то могу дать конекретную SQL комманду, но только вечером.

--
USU-Lug http://usu-lug.org.ru

Аватар пользователя Taras Taras (не проверено) 30 июня 2005 в 23:56

И все же возвращусь к вопросу Yanusа. Каким образом закинуть модуль .по Я поставил версию 4.6.1 Проблем при установки никаких. Но как импортировать модуль русификации ???