browscap

Установка Browscap

8 ноября 2017 в 0:34

Здравствуйте!
Соббсно сабж.
Есть работающий сайт на Drupal 7. Надо сделать мобильную версию.
Mobile theme поставил. Browscap поставил.
При настройке Mobile theme выдает:

0 Thanks

Перестал работать browscap

17 апреля 2017 в 13:08

Доброго дня всем друпалчане и всех с прошедшим праздником пасхи!

Такой вопрос. С недавних пор обнаружил, что перестала работать связка модулей browscap + mobile switch - она позволяла активировтаь отдельную тем при заходе с мобильных устройств.

0 Thanks

Мобильная версия и гугл

11 апреля 2017 в 14:38

Сайт работает на D7, для десктопов один шаблон, для всего остального (мобилы, планшеты) другой шаблон. Работает это все при помощи Mobile Switch и Browscap, т.е. определение по юзерагенту и загрузка соответствующего шаблона. Работает все отлично и шикарно, в принципе как и должно быть.

0 Thanks

разные views в зависимости от типа устройства

18 ноября 2015 в 17:38

Поставил Mobile Theme, Browscap и AT Core 7.x-3.2 (адаптивная тема).

Как можно сделать, чтобы при использовании адаптивной темы использовались другие views?

Спасибо!

0 Thanks

Browscap как определить браузер посетителя? (для мобильной версии сайта)

20 января 2013 в 15:26

Всем привет! Drupal 6
Установил модуль и пытаюсь определить браузер, пишу в page.tpl.php browscap_get_browser(), но мне выдается логическое значение FALSE и никакого объекта. Его можно только в модуле использовать?
P.S: кто как программно определяет, что посетитель "мобильный"?

0 Thanks

Апгрейд/даунгрейд/и снова апгрейд browscap приводят к такой проблеме

4 ноября 2010 в 8:50

Установил browscap 6.x-1.1, он некорректно работал с php-5.3 (даже баг такой есть).
Отапгрейдил его до 6.x-1.x-dev, через несколько дней в "обновлениях" увидел, что рекомендуется другая версия, ступил, установил ее (оказалось, что это предыдущая версия, а более "поздняя" дата это 30 сентября 2009 г. - на год не посммотрел :) ), сделал update.php, выдало такую ошибку:
An error occurred. https://domainname/update.php?id=124&op=do <br /> <b>Fatal error</b>: Call to undefined function _system_update_utf8() in <b>/home/user/data/www/domainname/htdocs/sites/all/modules/browscap/browscap.install</b> on line <b>58</b><br />
Я обратно перекопировал диру от 6.x-1.x-dev в sites/all/modules, сделал update.php - та же ошибка. Снес диру, по-новой распаковал, установил - ошибка повторяется.
В browscap.install в районе той строки такой код :

/**
 * Updates existing tables to UTF-8.
 */

function browscap_update_1() {
  return _system_update_utf8(array('browscap'));
  return _system_update_utf8(array('browscap_statistics'));
} // browscap_update_1

Ругань собственно на эту строчку return _system_update_utf8(array('browscap'));
Функции в этом файле не нахожу, где она вообще должна быть?! И какой у нее должен быть код?!
Или проблема в чем-то другом? Туплю...

0 Thanks