Вопрос обновления СУБД

Аватар пользователя links777 links777 11 октября в 18:25

после обновления ядра drupal с 8.9.16 до 9.2.7 получил в админке сообщения об ошибках:

Обнаружены ошибки
ВЕРСИЯ СУБД 5.6.41-84.1
Версия сервера базы данных 5.6.41-84.1 меньше, чем минимальная требуемая версия 5.7.8.
ОБНОВЛЕНИЯ БАЗЫ ДАННЫХ Требуется обновление
Для некоторых модулей требуется изменение структуры базы данных. Вы должны немедленно запустить скрипт обновления базы данных.

подскажите пожалуйста как это исправить??

Комментарии

Аватар пользователя ivnish ivnish 11 октября в 18:30

Это две разные проблему. Одну можно решить запустив скрипт /update.php а вторую - обновив СУБД на сервере или написав в поддержку хостинга

Аватар пользователя links777 links777 11 октября в 18:34

после запуска скрипта обновления получаю сообщения:

Несоответствие требованиям
Обнаружены ошибки
ВЕРСИЯ СУБД
5.6.41-84.1
Версия сервера базы данных 5.6.41-84.1 меньше, чем минимальная требуемая версия 5.7.8.
Проверено
ВЕБ-СЕРВЕР
Apache/2.4.41 (Ubuntu) PHP/7.4.14
PHP
7.4.14

Аватар пользователя bsyomov bsyomov 12 октября в 2:19

Сначала, надо обновить mysql сервер до 5.7.8+(как именно это сделать, сильно зависит от того, где запущен ваш сайт), а уже потом обновлять данные в базе с помощью update.php.