При установке модуля xls_serialization через composer получаю ошибку

Аватар пользователя DD 85 DD 85 2 сентября в 7:06

При установке модуля https://www.drupal.org/project/xls_serialization через composer получаю следующую ошибку:

Installation failed, reverting ./composer.json to its original content.
[RuntimeException]
Failed to clone https://git.drupalcode.org/project/coder.git, git was not found, check that it is installed and in your PATH env.
'git' is not recognized as an internal or external command,
operable program or batch file.

Как исправить?

0 Thanks

Лучший ответ

Аватар пользователя DD 85 DD 85 2 сентября в 19:53

Проблема решилась после вручную прописанного PATH к файлу C:\Program Files\Git\bin\git.exe через Система > Дополнительные параметры системы > Дополнительно > Параметры среды
И настройки Open Server Настройки > Сервер > Настройка использования переменной PATH > Свой PATH + Win PATH

Комментарии

Аватар пользователя ivnish ivnish 2 сентября в 7:25

После работы с composer.

Довольно туманное определение. С таким только экстрасенсов вызывать

Аватар пользователя DD 85 DD 85 2 сентября в 7:33

Я находил похожую тему, установил git-scm.com, но что с ним делать дальше и как им пользоваться не понимаю.

Аватар пользователя ivnish ivnish 2 сентября в 7:35

Он нужен для работы composer. Если composer продолжает ругаться на отсутствие гита, значит неправильно или не туда установили

Аватар пользователя DD 85 DD 85 2 сентября в 7:46

Установил как обычную программу. Настройки при инсталляции не менял. Правда, программы устанавливаются на диск С, а локалка у меня на D развёрнута. Надо куда-то конкретно устанавливать?

Аватар пользователя DD 85 DD 85 2 сентября в 19:53

Проблема решилась после вручную прописанного PATH к файлу C:\Program Files\Git\bin\git.exe через Система > Дополнительные параметры системы > Дополнительно > Параметры среды
И настройки Open Server Настройки > Сервер > Настройка использования переменной PATH > Свой PATH + Win PATH

Аватар пользователя DD 85 DD 85 2 сентября в 19:53

Но появилась новая проблема
Composer прекращает процесс установки сообщением
Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No replacement was suggested.
Что посоветуете для исправления?

Аватар пользователя DD 85 DD 85 2 сентября в 19:59

Composer ещё пишет такие строчки, не понимаю их значения.
Writing lock file
Generating autoload files
> Drupal\Core\Composer\Composer::preAutoloadDump
> Drupal\Core\Composer\Composer::ensureHtaccess