Прикрепленный файл в материале

Аватар пользователя Olips Olips 17 сентября 2016 в 18:58

Здравствуйте. Сразу прошу прощение, может глупый вопрос. Создаю материал, в "Управлении полями" добавляю новое поле, "Тип поля" - Файл, создаю материал, прикрепляю файл, но в материале он не отображается!!! Если в "Управлении отображением" ставлю "URL файла", урл отображается. Что делать не могу понять

Комментарии

Аватар пользователя Studio VIZA Studio VIZA 17 сентября 2016 в 19:24

Olips wrote:

Если в "Управлении отображением" ставлю "URL файла", урл отображается.

Olips wrote:

Должна отображаться ссылка на файл

Аватар пользователя Olips Olips 17 сентября 2016 в 19:33

мне нужно, чтоб в материале отображалась ссылка на вложенный файл, а не текст урл

Аватар пользователя dgastudio dgastudio 17 сентября 2016 в 20:00

значит у вас где то в теме есть шаблон файла, который и перекрывает нужный вывод

Аватар пользователя Totaku Totaku 17 сентября 2016 в 20:19

Если используете не свой шаблон, то лучше всего делать чайлд тему и все изменения делать там Smile

Аватар пользователя Olips Olips 17 сентября 2016 в 20:49

написал разработчику. подозреваю, что какая-то галочка в настройках темы ((((

Аватар пользователя Olips Olips 9 октября 2016 в 1:41

В общем переписка с разработчиком ни к чему не привела. Может кто сможет помочь? Готов заплатить

Аватар пользователя Olips Olips 9 октября 2016 в 2:09

http://prntscr.com/criatx

nid; ?>" class="<?php print $classes; ?> clearfix"<?php print $attributes; ?>>
<?php print render($title_prefix); ?>

<?php print render($content['field_image']); ?>

<?php if ($title && !$page): ?>
>
<?php if ($title): ?>
>
" rel="bookmark"><?php print $title; ?>

<?php endif; ?>

<?php endif; ?>

<?php if(!empty($user_picture) || $display_submitted): ?>
>
<?php print $user_picture; ?>
<?php print $submitted; ?>

<?php endif; ?>

<?php hide($content['field_image']); ?>

>
<?php print render($content); ?>

<?php if ($links = render($content['links']['node'])): ?>

><?php print $links; ?>
<?php endif; ?>

<?php print render($content['comments']); ?>

<?php print render($title_suffix); ?>

Аватар пользователя Mihail.space Mihail.space 9 октября 2016 в 19:39

Не. Page не нужен. Иногда поля в node.tpl выводят не в $content,а отдельно по ключу $content['fileld_name'].
У вас $content в ноде выводится и по идее если поле в настройках отображения не скрыто, то тоже должно выводиться.

Аватар пользователя Mihail.space Mihail.space 9 октября 2016 в 20:03

значит дело в шаблоне ноды. код который вы привели криво отобразился. можете отредактировать комментарий, в котором вы приводите код node.tpl но обернуть весь код в тег ?

Аватар пользователя Mihail.space Mihail.space 9 октября 2016 в 23:19

да нисколько. скиньте шаблон ноды куда нить. можно в скайпе . скайп есть в моих контактах

Аватар пользователя Studio VIZA Studio VIZA 9 октября 2016 в 13:05

Olips wrote:

До обновления шаблона все работало(((

Самое простое сейчас - на сервере найти бэкап темы, и восстановить её. Ориентируйтесь на дату за сутки до обновления.

Аватар пользователя Olips Olips 9 октября 2016 в 19:16

если бы... много правок делалось... я заметил, что не работает, когда прошло уже много времени(((