Тормозит сайт на drupal 7 при первом клике

Аватар пользователя maximowich

Добрый вечер. Сделал сайт на Drupal 7.
Очень странная проблема с производительностью.
После ввода адреса в строке браузера - сайт загружается нормально.
Далее при клике на любую ссылку - страница открывается секунд 10-20 (в этот момент клиенты уходят с сайта).
После того как загружается эта страница - все остальные страницы - весь сайт работает быстро.

вот адрес сайта - www.pikino.ru

Подскажите, как решить эту проблему.

Ключевые слова:
Тип материала:
Версия Drupal:
0 Спасибо

Комментарии

Аватар пользователя Lotar
Lotar 4 года назад

Все верно. Это называется кеширование. Если заходить например раз в час и поставить кеш на час, то будет быстро работать. Сайту не надо будет по новой все запросы повторять.

0 Спасибо
Аватар пользователя arcada.isb
arcada.isb 4 года назад

для диагностики поставьте devel

p.s. у меня все ок кстати

0 Спасибо
Аватар пользователя maximowich
maximowich 4 года назад

Проблема, что клиент заходя на сайт первый раз - делает первый клик и ждет долго - уходит с сайта.
Проблема при первом посещении - через кэш не решится. Попробую поковыряться в devel - спасибо за совет.

0 Спасибо
Аватар пользователя vitg
vitg 4 года назад

А не poormanscron ли виноват?

У вас большая посещаемость?

0 Спасибо
Аватар пользователя maximowich
maximowich 4 года назад
vitg написал:
А не poormanscron ли виноват?

У вас большая посещаемость?

Poormanscron не установлен.
Посещаемость маленькая. её практически пока нет. Один-два гостя одновременно.

0 Спасибо
Аватар пользователя k_dmitry
k_dmitry 4 года назад

Была подобная проблема, частично решилась, когда в админке прописал путь к tmp.
У меня ваш сайт нормально грузится.

0 Спасибо
Аватар пользователя maximowich
maximowich 4 года назад
k_dmitry написал:
Была подобная проблема, частично решилась, когда .
У меня ваш сайт нормально грузится.

А что означает "в админке прописал путь к tmp"?

0 Спасибо
Аватар пользователя Chyvakoff
Chyvakoff 4 года назад

тся и ться научись писать.

0 Спасибо
Аватар пользователя k_dmitry
k_dmitry 4 года назад
Chyvakoff написал:
тся и ться научись писать.

Спасибо, поправил...

0 Спасибо
Аватар пользователя Chyvakoff
Chyvakoff 4 года назад
k_dmitry написал:
Спасибо, поправил...

k_dmitry написал:
У меня ваш сайт нормально грузиться.

Моя не замечать.

0 Спасибо
Аватар пользователя k_dmitry
k_dmitry 4 года назад
k_dmitry написал:
грузится.

а так?

0 Спасибо
Аватар пользователя Chyvakoff
Chyvakoff 4 года назад

0 Спасибо
Аватар пользователя k_dmitry
k_dmitry 4 года назад

На странице admin/config/media/file-system, в "Временная папка" прописал "sites/default/files/tmp" и на хостинге поставил атрибуты 775

0 Спасибо
Аватар пользователя maximowich
maximowich 4 года назад
k_dmitry написал:
На странице admin/config/media/file-system, в "Временная папка" прописал "sites/default/files/tmp" и на хостинге поставил атрибуты 775

Спасибо! Сделал! Есть ощущение, что помогло.

0 Спасибо
Аватар пользователя morgusha
morgusha 3 года назад

сделал в tmp ток .htaccess загрузился и всё ???

0 Спасибо
Аватар пользователя Chyvakoff
Chyvakoff 3 года назад
morgusha написал:
и всё ???

Если ошибки не валятся - то всё.
Попробуй через админку модулей загрузить новый модуль и проверить темповую папку.

0 Спасибо