Как "заставить" ubuntu 16.04 работать с php5

Аватар пользователя loup54

Есть срочная работа, но не могу никак найти ответ как настроить лампу, чтобы работала с пхп5, желательно 5.3, если знаете подскажите. Работаю со старым друпалом поэтому и вопрос .

Тип материала:
Версия Drupal:
0 Thanks

Комментарии

Аватар пользователя loup54
loup54 1 месяц назад

На нее и xampp только с 7-кой устанавливается, другой нет, я не силен в конфигах линукса, но находил какой то мануал,там парень писал что можно установить 5 пхп , я установил, так же пробовал по его советам изменить настройки, ничего не вышло пакет пхп5 лежит просто мертвым грузом

Аватар пользователя itcrowd72
itcrowd72 1 месяц назад

Это какая версия друпала отказывается работать с php7?

Используй другой дистрибутив, например 14.04, если возможно

Аватар пользователя loup54
loup54 1 месяц назад

Отказывается 7.14, я вот уже и хочу менять систему, она из меня все соки выпила, вчера скачал 14.04 это просто последняя попытка найти решение, много нужных файлов, так много что залить даже некуда, поэтому пока не сношу

Аватар пользователя bsyomov
bsyomov 1 месяц назад
1

Версию 5.6.х можно установить из https://launchpad.net/~ondrej/+archive/php и запустить fpm, например.
С ней Drupal 7 должен работать даже довольно старый.
Вот тут есть о том, как это делается: https://askubuntu.com/questions/109404/how-do-i-install-different-upgrad...

Более старые версии php можно самостоятельно собрать из исходников, это не так и сложно... Установить куда-нибудь в /opt. Нагуглить как в убунте собрать php не проблема.
Опять же, можно запустить несклько экземпляров php-fpm разных версий.

А с настройками в любом случае надо будет разобраться.

PS Если нужен именно LAMP, то Apache работает с php-fpm через mod_proxy_fcgi (https://wiki.apache.org/httpd/PHP-FPM).

Аватар пользователя sas@drupal.org
sas@drupal.org 1 месяц назад
1

- Ой та проблемы, ставишь сколько нужно лампочек и пишешь небольшой sh для symlink ов разных.
- В https://vestacp.com/ можно хоть для каждого сайта свой пых выбирать.

Аватар пользователя Studio VIZA
Studio VIZA 1 месяц назад
1

Пиши скайп studioviza дам акк на 5.6 пхп в Германии. Глянем чо не так.

Аватар пользователя loup54
loup54 1 месяц назад

Спасибо,но у меня к сожалению скайпа просто нет, утром попробую поставить

Аватар пользователя Olegars
Olegars 1 месяц назад

да какие проблемы, можно хоть все версии пхп сразу поставить,если нужно apache то одна настраивается как модуль апаче, остальные как cgi, если php-fpm то вообще никаких проблем.

Аватар пользователя loup54
loup54 4 недели назад

За ссыль спасибо, хороший ресурс, а вот поисковик выдает только темы где этот вопрос поднимался, ответов 0 или 0.5

Аватар пользователя loup54
loup54 4 недели назад

Фильм норм

Аватар пользователя ХулиGUN
ХулиGUN 4 недели назад
loup54 написал:
Фильм норм

Ну так вот: Апач не нужен, родной. он только топливо жрёт)))

Аватар пользователя gun_dose
gun_dose 4 недели назад

How to downgrade php from 7 to 5 ubuntu 16.04

По этому запросу почти любая ссылка из первых трёх.